#21 Plplot build files with glibc-2.3.2

closed-out-of-date
nobody
None
5
2009-01-27
2004-04-26
Anonymous
No

Plplot build failed on my system (gentoo linux), with
the following error:
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include
-I../include -I../bindings/tcl -I../bindings/tk
-I../bindings/tk-x-plat -I/usr/X11R6/include
-I/usr/X11R6/include -I/usr/include/freetype2
-march=pentium4 -mcpu=pentium4 -Os -pipe
-fomit-frame-pointer -fexpensive-optimizations
-frerun-cse-after-loop -frerun-loop-opt
-falign-functions=4 -msse -msse2 -mmmx -mfpmath=sse
-mieee-fp -MT linuxvga.lo -MD -MP -MF
.deps/linuxvga.Tpo -c linuxvga.c -fPIC -DPIC -o
.libs/linuxvga.o
linuxvga.c:38: error: conflicting types for `pause'
/usr/include/unistd.h:414: error: previous declaration
of `pause'
make[2]: *** [linuxvga.lo] Error 1
make[2]: Leaving directory
`/var/tmp/portage/plplot-5.3.0/work/plplot-5.3.0/drivers'

I had to manually comment line 414 in unistd.h to make
it compile

Discussion

  • Andrew Ross

    Andrew Ross - 2009-01-27
    • status: open --> closed-out-of-date
     
  • Andrew Ross

    Andrew Ross - 2009-01-27

    linuxvga obsolete and no longer supported.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks