search form for multi-selection lists

  • Giovanni

    Giovanni - 2012-01-23

    Hi all.
    I have a search form based on my "viewall" but the resulting list gives me a unicode message for the multi-selection list field.
    No problem for the general view but only on the view resulting from the search form.
    We tried to write the following code in each column of the view:
    s = plominoContext.
    return str([''.join(', '.join()) for a in s]).replace("","")
    Now for a document with a single value for the multiselection list It seems the value is considered as a list.
    Any hint?


  • Eric Brehault

    Eric Brehault - 2012-01-24


    yes a multiselection field returns a list

    but what are you trying to do ?


  • Giovanni

    Giovanni - 2012-01-24

    I tried in this way:
    s= str(plominoContext.fieldname)
    return '' .join(''.join() for a in s).strip('').replace("'",'')

    Now it works.

  • Eric Brehault

    Eric Brehault - 2012-01-24

    I am still quite curious about what what you try to do :)
    Are you trying to remove empty values ?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks