I'm using player 1.6.5 on a Pioneer 2AT robot equipped with a SICKLms200.  When I try to use a laser proxy, I got the error :
"tried to get 'r' access to device 6665:6:0 but got '^@' access"

I didn't find anything on the mailing list on that issue.  Here is my configuration file :
# Desc: Basic Pioneer2DX
# CVS: $Id: pioneer.cfg,v 1.4 2005/04/05 04:18:30 gerkey Exp $
  name "p2os"
  provides ["6665:position:0"
  port "/dev/ttyS0"
  bumpstall 0
  direct_wheel_vel_control 0
  name "sicklms200"
  provides ["6665:laser:0"]
  port "/dev/ttyS1"
#  delay 35        # 35 or 0 give the same result
  range_res 10

The configuration seem to be good since a can get access to the laser data via playerv.

Here is my client code :

                 mp_LaserProxy = new LaserProxy(mp_Robot,0,'r');
                 if(mp_LaserProxy->access != 'r')
                    delete mp_LaserProxy;
                    mp_LaserProxy = 0;

Note that the mp_Robot is correctlty instanciated because I can use a prosition proxy without difficulty.  Moreover everything work well in simulation (stage.2-0-0a).

Thank for your help