I've already tried that. The strange thing is that I'm running player as root, and I still get the same error, and it has complete access.

player, seems to be running on user mode, even when having root privileges.

On Tue, Oct 12, 2010 at 3:45 PM, Rich Mattes <jpgr87@gmail.com> wrote:
> -----Original Message-----
> From: Martin Magnusson [mailto:martin.magnusson@oru.se]
> Sent: Tuesday, October 12, 2010 10:38 AM
> To: j.correa10@imperial.ac.uk; playerstage-users@lists.sourceforge.net
> Subject: Re: [Playerstage-users] Problem with Swissranger driver
>
> 2010-10-12 16:18, Javier Correa Villanueva skrev:
> > I've been trying to get a SR3000 camera to work using the swissranger
> > driver provided by player/stage on linux. Right now I'm getting this
> error:
> > USB error: couldn't opendir(): No such file or directory
> >
> > The different demo programs provided by Mesa Imaging works when run
> with
> > root privileges only, but swissranger driver can't load even when is
> run
> > with root privileges.
> >
> > Has anyone got this problem? Has anyone been able to fix it?
>
> Yes, I have the exact same problem when using a SR4000 camera. The code
> works in a standalone program, but when run through the Player driver,
> it can't open the USB port. I don't have a solution, though.

Are the USB port's permissions being set correctly?  It looks like there are some directions[1] for user access to the swissranger floating around, have you tried anything in there yet?

Rich

[1] http://wikiri.upc.es/index.php/Swissranger_SR3000


------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users