Hi, Peter:

Thanks for your reply. But all what I can get is the following staff:


jiapei@jiapei-laptop:~/Tools/playerstagegazebo/gazebo-svn-20110124/build$ make
/usr/bin/cmake -H/home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124 -B/home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124/build --check-build-system CMakeFiles/Makefile.cmake 0
/usr/bin/cmake -E cmake_progress_start /home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124/build/CMakeFiles /home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124/build/CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make[1]: Entering directory `/home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124/build'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124/build'
/usr/bin/cmake -E cmake_progress_start /home/jiapei/Tools/playerstagegazebo/gazebo-svn-20110124/build/CMakeFiles 0
jiapei@jiapei-laptop:~/Tools/playerstagegazebo/gazebo-svn-20110124/build$ 


By the way, are you using today's SVN?
Or are you building the released version gazebo-0.10.0.tar.bz2 ??


Cheers
JIA



On Fri, Jan 28, 2011 at 9:28 PM, Peter Nordin <peter.nordin@liu.se> wrote:
Hello

I am also having problems building the current Gazebo svn version, and I
hope that someone can help.
I have successfully (as far as I know) installed the necessary
dependencies, including

ode 0.11.1
bullet 2.77
assimp 2.0.863
ogre 1.7.2

I have also been able to make Gazebo cmake recognise that bullet has
been compiled with double precision.
I configured bullet with the following cmake options:

cmake ../ -DUSE_DOUBLE_PRECISION=ON -DBUILD_DEMOS=OFF -DBUILD_SHARED_LIBS=ON

and Gazebo with the following cmake options:

cmake ../ -Dbullet_include_dir=/usr/local/include/bullet
-Dbullet_include_dirs=/usr/local/include/bullet
-Dbullet_library_dirs=/usr/local/lib

gazebo cmake does not complain, but when I run make it will stop at 83%
while linking the gazebo executable with a bunch of undefined references
all relating to bullet
--------------------------
[ 83%] Building CXX object server/CMakeFiles/gazebo-exec.dir/main.o
Linking CXX executable gazebo
physics/bullet/libgazebo_physics_bullet.so: undefined reference to
`btHinge2Constraint::btHinge2Constraint(btRigidBody&, btRigidBody&,
btVector3&, btVector3&, btVector3&)'
physics/bullet/libgazebo_physics_bullet.so: undefined reference to
`btCollisionObject::~btCollisionObject()'
physics/bullet/libgazebo_physics_bullet.so: undefined reference to
`btAlignedFreeInternal(void*)'
.
and so on
.
--------------------------

After taking a look in server/CMakeFiles/gazebo-exec.dir/link.txt I
noticed that cmake had somehow forgot to add the bullet libs here, after
manually adding "-lBulletCollision -lBulletDynamics
-lBulletMultiThreaded -lBulletSoftBody -lBulletSoftBodySolvers_CPU" (the
bullet libs in my /usr/local/lib) to the end of this file, most of the
undefined references were "solved".

But now one remains:
--------------------------
[ 83%] Built target gazebo_av-shared
Linking CXX executable gazebo
physics/bullet/libgazebo_physics_bullet.so: undefined reference to
`gazebo::Geom::Update()'
collect2: ld returned 1 exit status
make[2]: *** [server/gazebo] Error 1
make[1]: *** [server/CMakeFiles/gazebo-exec.dir/all] Error 2
make: *** [all] Error 2
--------------------------

As far as i understand the gazebo::Geom:Update() should be in
"server/physics/libgazebo_physics.so" which is included in the link.txt
file.
I have no ideas how to get any further.

With regards
Peter Nordin


On 01/28/2011 10:21 AM, JIA Pei wrote:
>
> Hi, all:
>
> I'm not able to successfully install current Gazebo SVN installation.
> The downloaded SVN is just of today, say, Jan. 28, 2011 .
>
> Can anybody help me out how to install current Gazebo SVN?
>
> Cheers
> JIA
>
> --
> Welcome to Vision Open
> http://www.visionopen.com

------------------------------------------------------------------------------
Special Offer-- Download ArcSight Logger for FREE (a $49 USD value)!
Finally, a world-class log management solution at an even better price-free!
Download using promo code Free_Logger_4_Dev2Dev. Offer expires
February 28th, so secure your free ArcSight Logger TODAY!
http://p.sf.net/sfu/arcsight-sfd2d
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users



--
Welcome to Vision Open
http://www.visionopen.com