The undefined symbol is a player version mismatch, after running make install with player you need to reconfigure and re make stage.

Toby

2008/6/22 Apakanati <apakanati@hotmail.com>:

I hadn't tried it before so I attempted to install player 2.1.rc2 and stage
2.1.rc2.  The install went cleanly, however when I tried to run player on my
config file, I got:

---

trying to load /usr/local/lib/libstageplugin...
success
invoking player_driver_init()...
 Stage driver plugin init

 ** Stage plugin v2.1.0rc2 **
 * Part of the Player/Stage Project [http://playerstage.sourceforge.net]
 * Copyright 2000-2006 Richard Vaughan, Andrew Howard, Brian Gerkey
 * and contributors. Released under the GNU General Public License v2.
player: symbol lookup error: /usr/local/lib/libstageplugin.so.1: undefined
symbol: _ZN11DriverTable9AddDriverEPcPFP6DriverP10ConfigFileiE


---

I'm not really sure what is causing the above error.  The same error
occurred for an attempt at a player 2.05/stage 2.04, and one for the
original configuration that I was using the aforementioned code without
issues on with player 2.04 / stage 2.03.

Since I couldn't get any of those working for a reference, I decided to give
player 2.1.0 / stage 2.1.0 a shot.  That combination gave the same error as
the original post with the seg faults occurring with that bit of code.

Thanks again for your time and assistance,

Anu



Toby Collett-3 wrote:
>
> does this behaviour work with player 2.1rc2?
>
> Toby
>
>

--
View this message in context: http://www.nabble.com/Segmentation-faults-in-P-S-tp18046177p18051427.html
Sent from the playerstage-users mailing list archive at Nabble.com.


-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://sourceforge.net/services/buy/index.php
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users



--
This email is intended for the addressee only and may contain privileged and/or confidential information