Found the answer to my own question.  The error message "error (-1) reading packet on channel 0" is indeed related to the FTDI driver not being able to find the RMP.  The source of this particular problem was simply access control.  By executing as root (sudo player foo.cfg), the player server was able to find and connect to the RMP.

-Drew

On Thu, Dec 17, 2009 at 4:15 PM, Drew_S <dstovall@mail.utexas.edu> wrote:

Any luck resolving this error? (I'm getting the same error)

Based on the Knowledgebase at ftdichip.com, I updated my version of
canio_rmpusb.cc to list all the connected devices.  Turns out that I have no
devices.

I suspect that this is the root of the "error (-1)" problem that I'm having,
but I'm not sure how to fix it.  My Segway is turned on and connected.  The
results of "dmesg | grep FTDI" look promising.  After that, I'm not sure
what else to do to debug the problem...

-Drew

My code is exactly the same as the documentation found on this site:
http://www.ftdichip.com/Support/Knowledgebase/index.html?ft_listdevices.htm
ListDevices Function Documentation

The results of the dmesg test:
$ dmesg | grep FTDI
[  123.146256] USB Serial support registered for FTDI USB Serial Device
[  123.146325] ftdi_sio 1-6.3:1.0: FTDI USB Serial Device converter detected
[  123.146540] usb 1-6.3: FTDI USB Serial Device converter now attached to
ttyUSB0
[  123.146559] ftdi_sio: v1.5.0:USB FTDI Serial Converters Driver



Todd Flyr wrote:
>
>
> Hi,
> I have an RMP 100 that I've been following the instructions for (using
> ubuntu) and encountered the same issue you mentioned.  I made the changes
> that you suggested but I'm still not getting the connection completely set
> up.  When attempting to run the joystick.cfg, I'm getting "error (-1)
> reading packet on channel 0" and "error on write" messages after
> attempting to send the 0 speed information.  I am not certain if this is a
> canbus error or from player itself, but it is clearly not working.  All
> other aspects of the instructions seemed to work.  I have the devices
> connected via USB successfully.  I'm wondering if there's something
> obvious I've done wrong or if this is something you've encountered or if
> this might be something specific to using the RMP 100.  I am trying to use
> it in balance mode, which might be making a difference.
>
> Any insight would help.  Thanks in advance.
>
> -Todd
>
>
>
> Joshua S wrote:
>>
>> I have gotten things working, which required a slightly different setup.
>> Because I didn't have any Makefile references to -lcanbus I had to
>> initially modify <player-dir>/server/Makefile line to:
>> LIBS = -lpthread -lrt -lnsl -lcrypto -lraw1394  -lz -lltdl -ldl -ljpeg
>> -lGL -lGLU -lftd2xx
>>
>> I had problems at runtime because check_device exists in both
>> player(setpwc_api) and in ftd2xx. I modified the function check_device()
>> as it is defined in setpwc_api.[c/h] to setpwc_check_device() to keep
>> ftd2xx from calling the wrong check_device.  Next time I compile I will
>> try to target the ftd2xx linking with more precision to avoid this
>> problem.
>>
>> Thanks to everyone who worked on getting this together.
>>
>> Josh
>>
>>
>

--
View this message in context: http://old.nabble.com/Player-2.1.x-on-a-USB-segway-RMP-50-tp22007997p26835956.html
Sent from the playerstage-users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
This SF.Net email is sponsored by the Verizon Developer Community
Take advantage of Verizon's best-in-class app development support
A streamlined, 14 day to market process makes app distribution fast and easy
Join now and get one step closer to millions of Verizon customers
http://p.sf.net/sfu/verizon-dev2dev
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users