Hi, I recently saw the post mentioning that player -3.0.0 has been released. I have player-2.1.3 running properly on Ubuntu 9.04. Now I'm trying to install player-3.0.0 but getting some error. The output after entering the command
 cmake . is shown below.



root1@root1-desktop:~$ cd player-3.0.0
root1@root1-desktop:~/player-3.0.0$ cmake .
-- Player version 3.0.0
-- Operating system is Linux
-- Player will be installed to /usr/local
-- Large file support is disabled.
-- ===== Client Libraries =====
-- Python bindings for C client library will be built
-- Ruby bindings for C client library will not be built - could not find Ruby
-- Python bindings for C++ client library will not be built - disabled by user
-- Ruby bindings for C++ client library will not be built - could not find Ruby
-- PlayerC++ client library will be built with Boost::Thread support.
-- PlayerC++ client library will be built with Boost::Signals support.
-- ============================
--
-- ----- Processing driver make files -----
-- checking for module 'artoolkitplus'
--   package 'artoolkitplus' not found
-- checking for module 'GbxGarminAcfr'
--   package 'GbxGarminAcfr' not found
-- checking for module 'libstatgrab'
--   package 'libstatgrab' not found
-- checking for module 'libgarcia'
--   package 'libgarcia' not found
-- checking for module 'flexiport'
--   package 'flexiport' not found
-- checking for module 'GbxSmartBatteryAcfr'
--   package 'GbxSmartBatteryAcfr' not found
-- checking for module 'GbxSickAcfr'
--   package 'GbxSickAcfr' not found
-- checking for module 'hokuyo_aist'
--   package 'hokuyo_aist' not found
-- checking for module 'howl'
--   package 'howl' not found
-- checking for module 'libpqxx'
--   package 'libpqxx' not found
-- ----- Done -----
--
-- ===== Drivers =====
-- The following drivers will be built:
-- AioToSonar
-- accel_calib
-- acts
-- amcl
-- amtecpowercube
-- aodv
-- bitlogic
-- bumper2laser
-- bumpersafe
-- camera1394
-- cameracompress
-- camerauncompress
-- camerauvc
-- camerav4l
-- camerav4l2
-- camfilter
-- canonvcc4
-- clodbuster
-- cmucam2
-- cmvision
-- create
-- cvcam
-- deadstop
-- dummy
-- epuck
-- er1
-- erratic
-- fakelocalize
-- festival
-- flockofbirds
-- garminnmea
-- globalize
-- goto
-- imageseq
-- insideM300
-- iwspy
-- kartowriter
-- khepera
-- laserbar
-- laserbarcode
-- lasercspace
-- lasercutter
-- laserposeinterpolator
-- laserptzcloud
-- laserrescan
-- lasersafe
-- lasertoranger
-- linuxjoystick
-- localbb
-- mapcspace
-- mapfile
-- mapscale
-- mica2
-- microstrain
-- motionmind
-- mricp
-- nomad
-- obot
-- p2os
-- passthrough
-- pbslaser
-- ptu46
-- rangertolaser
-- readlog
-- relay
-- rflex
-- roboteq
-- robotracker
-- roomba
-- rs4leuze
-- rt3xxx
-- segwayrmp400
-- serialstream
-- serio
-- shapetracker
-- sickLDMRS
-- sickRFI341
-- sicklms200
-- sicklms400
-- sicknav200
-- sicks3000
-- simpleshape
-- skyetekM1
-- snd
-- sonartoranger
-- sonyevid30
-- sphere
-- tcpstream
-- upcbarcode
-- vec2map
-- vfh
-- videocanny
-- vmapfile
-- wavefront
-- wbr914
-- writelog
--
-- The following drivers will not be built:
-- XSensMT - XSENSMT_SOURCE_DIR was not set.
-- acr120u - Could not find header usb.h
-- alsa - Could not find header alsa/asoundlib.h
-- amtecm5 - Could not find header Device.h
-- artoolkitplus - Could not find package artoolkitplus
-- eedhcontroller - Disabled - probably doesn't build
-- flexiport - Could not find package flexiport
-- garcia - Could not find package libgarcia
-- gbxgarminacfr - Could not find package GbxGarminAcfr
-- gbxsickacfr - Could not find package GbxSickAcfr
-- hokuyo_aist - Could not find package hokuyo_aist
-- isense - Could not find header isense/isense.h
-- laservisualbarcode - Has not been updated to use dynamic message structures
-- laservisualbw - Has not been updated to use dynamic message structures
-- linuxwifi - Could not find header linux/wireless.h
-- mbicp - MBICP_SOURCE_DIR was not set.
-- nd - ND_SOURCE_DIR was not set.
-- nimu - Could not find header usb.h
-- oceanserver - Could not find package GbxSmartBatteryAcfr
-- phidgetAcc - Could not find header phidget21.h
-- phidgetRFID - Could not find header phidget21.h
-- phidgetifk - Could not find header phidget21.h
-- postgis - Could not find package libpqxx
-- rcore_xbridge - Could not find header libparticle.h
-- reb - Disabled by default
-- robotino - Could not find header robotinocom.h
-- segwayrmp - Disabled by default
-- service_adv_mdns - Disabled by default
-- sphinx2 - Disabled by default
-- sr3000 - Could not find header libusbSR.h
-- statgrab - Could not find package libstatgrab
-- stoc - Could not find header SVS/svsclass.h
-- unicapimage - Could not find header unicap.h
-- yarpimage - Could not find header yarp/os/all.h
-- ===================
--
-- ===== Examples =====
-- ====================
--
-- ===== Player utilities =====
-- XMMS plugin will not be built - XMMS not found
-- ============================
--
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
GLUT_Xmu_LIBRARY (ADVANCED)
    linked by target "lodo" in directory /home/root1/player-3.0.0/utils/pmap
    linked by target "lododriver" in directory /home/root1/player-3.0.0/utils/pmap
    linked by target "pmap" in directory /home/root1/player-3.0.0/utils/pmap
    linked by target "pmaptest" in directory /home/root1/player-3.0.0/utils/pmap

-- Configuring incomplete, errors occurred!
root1@root1-desktop:~/player-3.0.0$






 Can anyone help me with it. It will be greatly appreciated.
Thanks in advance,

Srikanth