Solved:

I tried the 2.6.22-3 kernel from debian backports and now it seems to work again. It appears to be a Linux Kernel problem.

/Peter

Peter Nordin wrote:
Followup:

After running strace on player with the command (strace player -d 9 
test.cfg) with test.cfg only starting the writelog driver. (There are no 
other drivers loaded so I am not really logging anything). I get the 
output bellow after sendig the signal SIGINT (same as Ctrl+C) to the 
player process. The player process hangs at "futex(0x80504a4, 
FUTEX_WAIT, 2, NULL ". After the destructor in writelog has been run.

After some searching I found others having the same problem with other 
software (not player related), and it seems to related to a Kernel bug 
in some cases.

Now I am wondering if there is someone else here that has run into this 
problem, or if there is someone using debian4.0 that has not run into 
this. If you haven't, what kernel version are you using. I am using 
2.6.18-5. I am gonna try some backported newer version later to see if 
that helps.

/Peter

--- SIGINT (Interrupt) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
poll([{fd=5, events=POLLIN}], 1, 0)     = 0
write(1, "Quitting.\n", 10Quitting.
)             = 10
munmap(0xb6588000, 8392704)             = 0
munmap(0xb5d87000, 8392704)             = 0
tgkill(5232, 5233, SIGRTMIN)            = 0
futex(0x8050484, 0x4 /* FUTEX_??? */, 1) = 0
futex(0x8054314, FUTEX_WAKE, 1)         = 0
write(6, "## Player version 2.1.0 \n## File"..., 311) = 311
close(6)                                = 0
munmap(0xb5584000, 4096)                = 0
write(1, "fileclosed\n", 11fileclosed
)            = 11
write(1, "shutdown\n", 9shutdown
)               = 9
write(1, "destructor\n", 11destructor
)            = 11
futex(0x80504a4, FUTEX_WAIT, 2, NULL

The output above is from player CVS but I get the same result from 2.0.4


Peter Nordin wrote:
  
Hello

I am having  a problem when I want to exit player while the writelog 
driver is used.
To exit player i press Ctrl+C in the console window were it is running. 
When I do this all of my activated drivers close down nicely before 
player exits. If i have the WriteLog driver activated  however, the 
player process never exits and I am forced to kill the process.

After adding some printf lines to writelogg.cc I could see that the 
writelog driver also exits nicely, it close the log-file, unsubscribe 
from interfaces and finally runs the writelog destructor. After this 
nothing more happens.  The logfiles are working but it is annoying to 
have to manually kill player after every run. I have tried using both 
playervcr and "alwayson" / "always record" options, same result.

Before using  Debian4.0 I have used  Debian 3.1 without having this 
problem. I have also seen player running in Suse (dont know what 
version) without this problem.

Does anyone have an Idea of what could be causing this. It happens in 
both player 2.0.4 and the latest CVS version. One thing I have noticed 
is that writelog.cc has a destructor, sicklms200.cc (another driver I am 
using) don't .  I guess it inherits it from the Driver class. I don't 
know if this is helpful.

/Peter

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users
  
    


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users