Thanks for you reply,
I have been trying differents options with the bumblebee stereo camera

with the following config file
driver
(
  name "camera1394"
  provides [ "camera:0" ]
  node 0
  framerate 15
  mode "640x480_mono"
  bayer "RGGB"
  method "DownSample"
)
 
driver
(
  name "camera1394"
  provides [ "camera:1" ]
  node 1
  framerate 15
  mode "640x480_mono"
  bayer "RGGB"
  method "DownSample"
)

If I run videoplayer with camera 0 (default options) I can see the right
image in color (even if the mode is "mono")
When I try to run another instance of videoplayer with camera 1
$> ./videoplayer localhost 6665 1
I get the following message on the server:

accepted TCP client 1 on port 6665, fd 10
error   : Could not find camera with node 1, port 0
error   : Driver failed to Setup (-1)
error   : StopThread called when state != running or restarting (0)

-----
Trying changing the port from 0 to 1 in the camera:1, it read another
port of the firewire card, and I get the following message

accepted TCP client 1 on port 6665, fd 10
error   : Could not find camera with node 0, port 1
error   : Driver failed to Setup (-1)
error   : StopThread called when state != running or restarting (0)

If I have another camera on the other port I get that image in the client for port 1.

-----
I read that the mode of the bumblebee is FORMAT7 and the right and left
images are in the MSB and LSB in the 16bits (RAW16/MONO16 modes)


When I try the "FORMAT7_MODE0" mode of camera1394 driver,
I get the following message

ibdc1394 error: RAW1394 failure: in dc1394_format7_get_packet_size (format7.c, line 441): Could not get packet size

libdc1394 error: RAW1394 failure: in dc1394_video_get_bandwidth_usage (control.c, line 1833): Could not get BPP

libdc1394 error: Error: Failed to setup DMA capture
warning : DMA capture failed; falling back on RAW method
error   : unable to open camera in VIDE0 or RAW modes
error   : Driver failed to Setup (-1)
error   : StopThread called when state != running or restarting (0)

-----
Changing the mode to "640x480_rgb" I get the attached image only in the camera:0.

----
I don't understand ieee1394 or libdc1394, I only try many options but
they did not work.

Can the player camera1394 driver get separate right and left images ?
How should be the config file to get that ?

I'll be much appreciate if someone could help me to solve it
best regards

-----
Gonzalo F. Perez Paina
Centro de Investigación en Informática para la Ingeniería, CIII.
Universidad Tecnológica Nacional. Facultad Regional Córdoba.
Maestro M. López esq. Cruz Roja Argentina. CP X5016ZAA
gperez@scdt.frc.utn.edu.ar

--- El mié 24-feb-10, Rich Mattes <jpgr87@gmail.com> escribió:

De: Rich Mattes <jpgr87@gmail.com>
Asunto: Re: [Playerstage-users] bumblebee stereo camera
Para: playerstage-users@lists.sourceforge.net
Fecha: miércoles, 24 de febrero de 2010, 20:41

Camera1394 has additional “port” and “node” options you should look at (http://playerstage.sourceforge.net/doc/Player-cvs/player/group__driver__camera1394.html).  I have a feeling that the BumbleBee is showing up as two different cameras on the firewire bus.  Camera1394 will default to the first camera it finds, even if the camera is already in use.  I think the utility “plugreport” will show you what is connected to the Firewire bus, and it should be available from your distro’s repositories (in Fedora, it’s in the libiec61883-utils package).

 

From: Gonzalo Fernando Perez Paina [mailto:gonzalofperez@yahoo.com.ar]
Sent: Wednesday, February 24, 2010 4:19 PM
To: PlayerStage list
Subject: [Playerstage-users] bumblebee stereo camera

 

Greetings,

I am trying to use the PointGrey Bumblebee stereo camera with Player version 3.0.1
I can get the camera image (the right) with the following configuration file
driver
(
  name "camera1394"
  provides [ "camera:0" ]
  framerate 15
  mode "640x480_mono"
  bayer "RGGB"
  method "DownSample"
)
and it looks fine, the refresh and the color are fine.
I try to get the other camera image (the left) copying another similar driver section
providing "camera:1" interface but it did not work.
How it should be the configuration file to get the the left and right images in two separate intefaces ?
I am using
- kernel version 2.6.26-2-686
- libdc1394-22
- libraw1394-11

I will be appreciated if someone could help me
thanks in advance

-----
Gonzalo F. Perez Paina
Centro de Investigación en Informática para la Ingeniería, CIII.
Universidad Tecnológica Nacional. Facultad Regional Córdoba.
Maestro M. López esq. Cruz Roja Argentina. CP X5016ZAA
gperez@scdt.frc.utn.edu.ar

 



Encontra las mejores recetas con Yahoo! Cocina.
http://ar.mujer.yahoo.com/cocina/


-----Adjunto en línea a continuación-----

------------------------------------------------------------------------------
Download Intel® Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev

-----Adjunto en línea a continuación-----

_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users



Encontra las mejores recetas con Yahoo! Cocina.
http://ar.mujer.yahoo.com/cocina/