thanks for all of your help.  Unfortunately I was working with these robots on a temporary detail and it is time for me to stop trying to configure them. It is probably an error in the linux configuration as others have been able to get their robots to work just fine. 
 
Thanks again for the help
 
Stephen Reiman

Brian Gerkey <gerkey@ai.stanford.edu> wrote:
stephen reiman wrote:
> Should I try to flash the robot to the latest versions of P2os or other
> programs?
>
> */stephen reiman /* wrote:
>
> I tried using playerjoy and had the same result.
>
> How important is the OS? I have been using Mandrake 10 instead of
> Debian or Redhat.

I am stumped. Neither the P2OS version nor the Linux distro should make
any difference. Is there anything else odd about your setup? Maybe a
radio modem?

Here are two wildly unlikely hypotheses:

(1) Your version of P2OS (or AROS, etc.) is blazingly new and behaves
differently enough from older versions that Player's p2os driver doesn't
work with it.

(2) The unit conversion parameters for that robot are wrong, resulting
in Player's sending the robot really tiny velocities. You could test
this by raising the maximum speeds for the p2os driver (max_xspeed and
max_yawspeed in the .cfg file) and then running playerjoy with higher
speeds (-speed and -turnspeed on the command line). Try multiplying
them all by 10 or 100 (then stand back).

brian.

--
Brian P. Gerkey gerkey@ai.stanford.edu
Stanford AI Lab http://ai.stanford.edu/~gerkey


-------------------------------------------------------
This SF.Net email is sponsored by: IntelliVIEW -- Interactive Reporting
Tool for open source databases. Create drag-&-drop reports. Save time
by over 75%! Publish reports on the web. Export to DOC, XLS, RTF, etc.
Download a FREE copy at http://www.intelliview.com/go/osdn_nl
_______________________________________________
Playerstage-users mailing list
Playerstage-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/playerstage-users


Do you Yahoo!?
Yahoo! Mail - now with 250MB free storage. Learn more.