Hello,

I was trying to install Player/Stage. The player(3.0.2) was installed successfully however when I tried to compile Stage(4.0.0) these error showed up:
Scanning dependencies of target stageplugin
[ 82%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_driver.o
[ 84%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_actarray.o
[ 86%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_blobfinder.o
[ 87%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_gripper.o
[ 89%] Building CXX object libstageplugin/CMakeFiles/stageplugin.dir/p_simulation.o
/home/asus/Stage-4.0.0/libstageplugin/p_simulation.cc: In member function ‘virtual int InterfaceSimulation::ProcessMessage(QueuePointer&, player_msghdr_t*, void*)’:
/home/asus/Stage-4.0.0/libstageplugin/p_simulation.cc:155:52: error: ‘PLAYER_CAPABILITIES_REQ’ was not declared in this scope
/home/asus/Stage-4.0.0/libstageplugin/p_simulation.cc:451:26: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
make[2]: *** [libstageplugin/CMakeFiles/stageplugin.dir/p_simulation.o] Error 1
make[1]: *** [libstageplugin/CMakeFiles/stageplugin.dir/all] Error 2
make: *** [all] Error 2
I downloaded the newest package for Stage on their website.
Do i need to install anything???

Thanks alot,
Kev