#93 player needs libtool

closed
stage (111)
5
2005-01-06
2005-01-04
No

I have installed player-1.6, stage-1.6.0.

wr@[ikarus]:~/forschung/software/ps> bin/player
share/stage/worlds/simple.cfg
** Player v1.6 ** [TCP]

Parsing configuration file "share/stage/worlds/simple.cfg"
error : Sorry, no support for shared libraries, so can't load
plugins
error : failed to load plugin: libstage

Apparently, player's LoadPlugin() never loads any plugin. There
must be some autoconf/etc. related error here. When I
uncomment the related #ifdefs, the compiler says that ltdl is
needed (contained in the libtool package). It would be nice if such
a comment is included in the ./configure --help output.

After installing libtool, everything compiled fine. But now, GTK
errors appear:

wr@[ikarus]:~/forschung/software/ps> bin/player
share/stage/worlds/simple.cfg
** Player v1.6 ** [TCP]

Parsing configuration file "share/stage/worlds/simple.cfg"
PLAYERPATH: /home/wr/forschung/software/ps/lib
trying to
load /home/wr/forschung/software/ps/lib/libstage...success
invoking player_driver_init()...success
Stage driver creating 1 device
mapping device 6665.31.0 => "simple.world" [Include
pioneer.inc][Include map.inc]
(player:22599): Gtk-CRITICAL **: file gtkstatusbar.c: line 296
(gtk_statusbar_push): assertion `GTK_IS_STATUSBAR
(statusbar)' failed
done.
Stage driver creating 1 device
mapping device 6665.4.0 => "robot"
Stage driver creating 1 device
mapping device 6665.5.0 => "robot.ranger:0"
Stage driver creating 1 device
mapping device 6665.6.0 => "robot.laser:0"
Using device table:
------------------------------------------------------------
0 driver stage id 6665:simulation:0
1 driver stage id 6665:position:0
2 driver stage id 6665:sonar:0
3 driver stage id 6665:laser:0
------------------------------------------------------------
listening on port 6665

(player:22599): Gtk-CRITICAL **: file gtkstatusbar.c: line 268
(gtk_statusbar_get_context_id): assertion `GTK_IS_STATUSBAR
(statusbar)' failed

(player:22599): Gtk-CRITICAL **: file gtkstatusbar.c: line 322
(gtk_statusbar_pop): assertion `GTK_IS_STATUSBAR
(statusbar)' failed

(player:22599): Gtk-CRITICAL **: file gtkstatusbar.c: line 296
(gtk_statusbar_push): assertion `GTK_IS_STATUSBAR
(statusbar)' failed

I'm running KDE 3.3.2 but so far every GTK app ran smoothly on
my machine.

Any help?
wr

Discussion

  • Brian Gerkey

    Brian Gerkey - 2005-01-04
    • labels: 389124 --> stage
    • assigned_to: gerkey --> rtv
     
  • Brian Gerkey

    Brian Gerkey - 2005-01-04

    Logged In: YES
    user_id=211013

    Good point on the libtool dependency. I've just added a
    configure-time warning, as well as augmented the run-time
    error; they both suggest that the user install libtool in
    order to get libltdl.

    I'll now reassign this bug to Richard, who can handle the
    Stage question.

    In the future, please submit separate bugs for each separate
    problem.

    brian.

     
  • Richard Vaughan

    Richard Vaughan - 2005-01-05

    Logged In: YES
    user_id=139639

    I don't know why you have that Stage error. I can't reproduce it. If you
    haven't already tried it, you should probably completely rebuild Stage
    after installing libtool. After that, if you still have the problem, please
    report back with your GTK version number (don't worry about KDE - it's
    not relevant).

    Richard.

     
  • Willi Richert

    Willi Richert - 2005-01-05

    Logged In: YES
    user_id=1187949

    With the new 1.6.1 version of stage it does not compile on my FC3
    machine: After configuring correctly make install prints:

    Stage will be built for a i686-pc-linux-gnu system, with the following tools
    and options:
    C compiler: gcc -g -O2
    C++ compiler: g++ -g -O2

    Stage will be installed in:
    /home/wr/forschung/software/ps/

    To see the configuration options, do:
    ./configure --help

    When you're satisfied with the configuration, type 'make install'.

    Making install in replace
    make[1]: Entering directory `/home/wr/install/ps/stage-1.6.1/replace'
    make[2]: Entering directory `/home/wr/install/ps/stage-1.6.1/replace'
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Leaving directory `/home/wr/install/ps/stage-1.6.1/replace'
    make[1]: Leaving directory `/home/wr/install/ps/stage-1.6.1/replace'
    Making install in src
    make[1]: Entering directory `/home/wr/install/ps/stage-1.6.1/src'
    if /bin/sh ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I..
    -Wall -I../replace -I/home/wr/forschung/software/ps//include
    -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
    -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2
    -I/usr/include/freetype2/config-I/usr/include/glib-2.0
    -I/usr/lib/glib-2.0/include -g -O2 -MT stagecpp.lo -MD -MP -MF
    ".deps/stagecpp.Tpo" \
    -c -o stagecpp.lo `test -f 'stagecpp.cc' || echo './'`stagecpp.cc; \
    then mv -f ".deps/stagecpp.Tpo" ".deps/stagecpp.Plo"; \
    else rm -f ".deps/stagecpp.Tpo"; exit 1; \
    fi
    g++ -DHAVE_CONFIG_H -I. -I. -I.. -Wall -I../replace
    -I/home/wr/forschung/software/ps//include -I/usr/include/gtk-2.0
    -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
    -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2
    -I/usr/include/freetype2/config -I/usr/include/glib-2.0
    -I/usr/lib/glib-2.0/include -g -O2 -MT stagecpp.lo -MD -MP
    -MF .deps/stagecpp.Tpo -c stagecpp.cc -fPIC -DPIC -o .libs/stagecpp.o
    stagecpp.cc: In function `char* wf_read_string(int, char*, char*)':
    stagecpp.cc:36: error: invalid conversion from `const char*' to `char*'
    stagecpp.cc: In function `char* wf_read_tuple_string(int, char*, int,
    char*)':
    stagecpp.cc:41: error: invalid conversion from `const char*' to `char*'
    make[1]: *** [stagecpp.lo] Error 1
    make[1]: Leaving directory `/home/wr/install/ps/stage-1.6.1/src'
    make: *** [install-recursive] Error 1

     
  • Willi Richert

    Willi Richert - 2005-01-05

    Logged In: YES
    user_id=1187949

    Sorry, I've just now seen rtv's bug report in this regard.

     
  • Willi Richert

    Willi Richert - 2005-01-05

    Logged In: YES
    user_id=1187949

    Same error after rebuilding.
    Version: gtk+,gtk 1:1.2.10-33.5.2.kde
    Gnome 2.6
    Fedora Core 2

     
  • Willi Richert

    Willi Richert - 2005-01-06

    Logged In: YES
    user_id=1187949

    I switched to player's CVS version. When configuring I get
    checking for lt_dlopenext in -lltdl... yes
    ...
    Support for plugin drivers will be included.

    Player will build RTK-based components using:
    CPPFLAGS: -I/usr/local/include -I/usr/include/gtk-2.0
    -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
    -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2
    -I/usr/include/freetype2/config -I/usr/include/glib-2.0
    -I/usr/lib/glib-2.0/include
    LDFLAGS: -Wl,--export-dynamic -L/usr/local/lib -lrtk -ljpeg
    -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0
    -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0

    make install works fine. When I then try to start player with stage I get:
    bin/player share/stage/worlds/everything.cfg
    ** Player v1.7 ** [TCP]

    Parsing configuration file "share/stage/worlds/everything.cfg"
    error : Sorry, no support for shared libraries, so can't load plugins.
    error : You should install libltdl, which is part of GNU libtool, then
    re-compile player.
    error : failed to load plugin: libstage

    I have installed in /usr/lib:
    -rw-r--r-- 1 root root 26600 Apr 12 2004 /usr/lib/libltdl.a
    -rwxr-xr-x 1 root root 789 Apr 12 2004 /usr/lib/libltdl.la
    lrwxrwxrwx 1 root root 16 Jan 4 14:04 /usr/lib/libltdl.so ->
    libltdl.so.3.1.0
    lrwxrwxrwx 1 root root 16 Oct 7 13:17 /usr/lib/libltdl.so.3 ->
    libltdl.so.3.1.0
    -rwxr--r-- 1 root root 25996 Apr 12 2004 /usr/lib/libltdl.so.3.1.0

    I have attached config.log and make.log

     
  • Willi Richert

    Willi Richert - 2005-01-06

    Make log with player cvs version

     
  • Willi Richert

    Willi Richert - 2005-01-06

    config.log with player cvs version

     
  • Brian Gerkey

    Brian Gerkey - 2005-01-06

    Logged In: YES
    user_id=211013

    My mistake; got the logic wrong in the autoconf library
    test. It's fixed in CVS; update, autoreconf, configure,
    make, make install.

    brian.

     
  • Willi Richert

    Willi Richert - 2005-01-06

    Logged In: YES
    user_id=1187949

    Now everything works. I'll close this bug.

    Thank you very much!

     
  • Willi Richert

    Willi Richert - 2005-01-06
    • status: open --> closed
     

Log in to post a comment.