makeunix script in zip distribution

Help
qew
2007-07-17
2013-04-25
  • qew

    qew - 2007-07-17

    Hi!

    I try to compile Pixie 2.2.1 from zip source distribution and automake from makeunix script give these errors:

    automake: unrecognized option -- `-f'
    Try `automake --help' for more information.
    rib.y: conflicts: 1 shift/reduce
    sl.y: conflicts: 1 shift/reduce

    What version of automake should I use? I tried 1.4, 1.7, 1.8 and 1.9. Or is this not automake problem?

     
    • qew

      qew - 2007-07-17

      An where is install.sh?

       
      • Okan Arikan

        Okan Arikan - 2007-07-17

            For making the unix distribution, you should use the tgz file. It has all the file permissions set and has all the required macros included.

           Okan

         
    • qew

      qew - 2007-07-17

      Thanks!

      But why is architecture column set to "Platform-Independent" for Pixie-src-2.2.1.zip distribution?

       
      • Okan Arikan

        Okan Arikan - 2007-07-17

           This is a good point,

           .zip is only good for Windows
           .tgz is good for all major Unix systems

           There's no selection in sourceforge that covers this distinction yet.

           Okan

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks