Pixie binares invalid on Ubuntu 12.04

  • Atom

    Atom - 2012-07-27

    Hi All,

    I am new to Linux, but have been using Pixie on Windows. When I tried Pixie on Ubuntu 12.04 I found that sdrc no longer works. It generates stackoverflows when compiling surface and light shaders. Note: It did compile the fog.sl shader just fine.

    Can some guru re-compile Pixie for these modern distro and repost working binaries?

    I tried following the compile instructions for Unix but they no longer work. When I paste the lines of code into the Terminal nothing happens.

    Any help is appreciated.



  • Atom

    Atom - 2012-07-27

    Ok, so I am giving compiling a try but remember I am a complete newbie as far as Linux and compiling goes.

    I am working with Ubuntu 12.04.

    Here is what I have done.
    I pulled the source code from here:http://pixie.svn.sourceforge.net/viewvc/pixie/trunk/
    I extracted the files into a folder called "pixie-trunk"
    I press CTRL-ALT-T to bring up the terminal.
    I have used the cd command to change to the directory of "pixie-trunk"

    Let the typiing begin.
    sudo apt-get install perl csh libtool automake autoconf flex bison
    csh makeunix
    make install

    After typing the suggested commands you will find it does not work. On my system I see some errors about tiffio missing and x11.
    I dig around on the interweb and find a few more commands to type…
    sudo apt-get install libx11-dev
    sudo apt-get install libtiff4-dev libtiff4

    This got me to the point where the ./confgure command actually worked!
    But it still will not compile. After looking through even more messages it looks like fltk is not installed so I type

    sudo apt-get install libfltk1.3-dev libfltk1.3

    Even though the above command for fltk seemed to work from the terminal, (note, I am using the same terminal session for all this typing, I don't know if that matters) when I re-issue ./configure I see a message that fltk is not installed.

    When I type make, I get errors and I still have not binaries of Pixie to work with.

  • Natacha

    Natacha - 2012-07-27


    do you actually need FLTK?

    The reason I ask is because I don't, and that didn't prevent me from compiling Pixie.

    Here is what the end of the output of ./configure looks like to me:

    config.status: executing depfiles commands
    config.status: executing libtool commands
    --->            FLTK not found.
    ---> You can download it from www.fltk.org
    ---> show will not be built.
    --->            OpenEXR not found.
    ---> You can download it from www.openexr.org
    ---> openexr display driver will not be built.
     Installation info:
         PIXIEHOME:  /home/nat/pixie
     Documentation:  /home/nat/pixie/doc
           Shaders:  /home/nat/pixie/shaders
              RIBs:  /home/nat/pixie/ribs
          Textures:  /home/nat/pixie/textures
          Displays:  /home/nat/pixie/displays
       Procedurals:  /home/nat/pixie/procedurals
           Modules:  /home/nat/pixie/modules
    To build Pixie:
    >make install

    So no FLTK and no OpenEXR, but still, I can do "make" and then "make install" and it successfully compiles and installs pixie.

    Hoping this helps,


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks