Opengl wrapper not found error

Lukasz
2007-04-23
2013-04-25
  • Lukasz

    Lukasz - 2007-04-23

    Whenever I try to use show to preview photon maps or irradiance I get a warning opengl wrapper not found. I tried it on two computers with the same result and with different versions of Pixie. Anyone came across this issue?

     
    • George Harker

      George Harker - 2007-04-23

      Hi Lukasz,

      Which OS are you on, and which release / version of Pixie are you using.  Is it a prepackage binary release or one you compiled yourself.

      Pixie looks in

      $PIXIEHOME/modules/

      for the opengl wrapper.  The wrapper is called gui.so / gui.dll or similar.

      Is that folder present, and the shared lib there?

      Cheers

      George

       
      • Remik Ziemlinski

        George,

        I have the same problem when compiled on either i686 and ia64.  I had no $PIXIEHOME/modules directory.  This is what I found

        locate gui.so
        /net2/rsz/i686/pixie/pixie-2.1.1/lib/Pixie/modules/gui.so
        echo $PIXIEHOME
        /net2/rsz/i686/pixie/pixie-2.1.1

        So then I did this, but it didn't help:

        mkdir $PIXIEHOME/modules
        ln -s /net2/rsz/i686/pixie/pixie-2.1.1/lib/Pixie/modules/* $PIXIEHOME/modules

        Remik

         
        • George Harker

          George Harker - 2007-06-15

          Hi Remik,

          Check the configure log.  We made fltk optional (to support farm machines etc).  But you will need fltk to use show etc and the gui module.

          Probably configure didn't find fltk so it didn't build the gui module.

          Cheers

          George

           
    • Lukasz

      Lukasz - 2007-04-24

      Sorry for the delay but I wanted to test it on both computers. I'm running WinXP on both and Pixie 1.7.2. Apparently there was no proper path defined. But the same thing doesn't work for Pixie 1.7.6 where it produces the same error regardless what path settings I use. I didn't try it with Pixie 2 due to the raytracing bug which I have mentioned in my previous post so I can't tell how it works.

      Thanks for help. The "show" opened my eyes to many possibilities.

       
    • Remik Ziemlinski

      Here's some boring stuff from my config.log.  Does it look okay?  Thanks,

      ./configure --prefix=/net2/rsz/i686/pixie/pixie-2.1.1 --with-fltk-config=/net2/rsz/i686/fltk-1.1.7/ --with-openexr-prefix=/net2/rsz/i686/openexr-1.4.0/

      configure:21786: checking for fltk-config
      configure:21804: found /net2/rsz/i686/fltk-1.1.7/bin//fltk-config
      configure:21817: result: /net2/rsz/i686/fltk-1.1.7/bin//fltk-config

      configure:21851: checking for FLTK with GL support
      configure:21889: g++ -o conftest -O3 -I/net2/rsz/i686/fltk-1.1.7/include   -L/net2/rsz/i686/openexr-1.4.0/lib/  conftest.cc -lpthread -lm -ldl  >&5
      configure:21928: result: yes

      ac_cv_env_FLTK_CONFIG_set=
      ac_cv_env_FLTK_CONFIG_value=
      ac_cv_path_FLTK_CONFIG=/net2/rsz/i686/fltk-1.1.7/bin//fltk-config
      CFLAGS='-O3 -I/net2/rsz/i686/fltk-1.1.7/include'
      CXXFLAGS='-O3 -I/net2/rsz/i686/fltk-1.1.7/include'
      FLTK_CONFIG='/net2/rsz/i686/fltk-1.1.7/'
      FLTK_CXXFLAGS=''
      FLTK_LDFLAGS=''

      Remik

       
    • Remik Ziemlinski

      I reconfigured with

      --with-fltk-config=/net2/rsz/i686/fltk-1.1.7/bin/fltk-config

      and after recompiling, it now works.  "show" is pretty cool!

      Remik

       
  • HakMeister

    HakMeister - 2012-05-18

    Perhaps a bit late, but I ran into this problem on OSX Lion. The issue in my case was caused by building with cmake instead of using the "makeunix/configure/make/make install" route. The former did not build guy.so, and placed the binaries under /usr/local/Pixie. The latter did and created the proper directories under /Applications/Graphics/Pixie. Note that you also have to install fltk for the show utility.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks