Thanks a lot! I started mass-reassigning some bugs, including "everything related to the source list and to importing" --> to the "source list" component. I'm unsure if "importing" should be a separate component or if "source list" should be renamed to "importing" though. I don't really mind either way, but if you want a better distinction between the actual source list UI and the discoverer bugs, feel free to edit the components.