PIP JDBC error with MTM servers

Help
2008-02-29
2013-04-30
  • Dennis Ballance

    Dennis Ballance - 2008-02-29

    I am having trouble with a JDBC connection.

    Background:
    I copied the entire pip_v01 folder onto our test server, then added all the globals from the pip mumps.dat into our .gld file (as names). Hence, PIP has access to both its globals and to our existing globals. I also turned off journaling, for now.

    Symptom:
    I just set up a remote JDBC connection using SQLExplorer in Eclipse, but when I try to connect I get this message:

       Invalid Message Format from MTM:Check Server:MTM Failed

    Other info:
    I found mtm/MTM_PIPV01.LOG, which contains the following:

    SCA ERROR:    Reason Code: -19
    ERROR: Message: SCAMTM NOTIFICATION: No active servers.
    ERROR: File: mtmcomm.c Line: 1059

    Any ideas why no MTM servers would be starting? Up to the message "MTM_PIPV01 process started. Process ID = 20361", this log looks identical to the QEMU log (on the QEMU system MTM servers are successfully started).

    Thanks!
    Dennis

     
    • K.S. Bhaskar

      K.S. Bhaskar - 2008-02-29

      Dennis --

      In the virtual machine, look at /etc/init.d/pipv01 (I think that's the file name - or at least, it's something close).  Notice that it is linked to from /etc/rc*.d/

      That's what starts the MTM and application servers, and you should replicate that functionality on your server.

      Regards
      -- Bhaskar

       
      • Dennis Ballance

        Dennis Ballance - 2008-02-29

        Thanks, Bhaskar.

        Ok, I did that. I actually had previously started pip by running pipstart as the expected user. I expect my problem is that I don't have some essential environment variable correctly defined (since, after all, our gtm_dist is in a different place, I'm running as a different user, and a few odds and ends like that), I'm just not sure how to find it.

        Dennis

         
    • Edwin Clubb

      Edwin Clubb - 2008-03-06

      The M server processes were failing to start and printing these errors to the PBSSRV_*.mje error log files:

      ERROR:  Reason Code 22
      ERROR:  Message: Invalid argument
      ERROR:  Source file: server.c Line Number 436

      Eventually we determined that the default kernel parameters (on Debian anyway) for IPC messages were incorrect.  Setting these parameters with the sysctl utility (and also in /etc/sysctl.conf) fixed the problem:

      kernel.msgmnb=6553600
      kernel.msgmax=1048568

      Ed

       
      • K.S. Bhaskar

        K.S. Bhaskar - 2008-03-07

        Ed --

        You should look at the parameters in the virtual machine.  It was for reasons such as this that we decided to make the initial distribution a virtual machine.

        Regards
        -- Bhaskar

         
  • Marcin Jachurski

    Thank You Egclubb for Your advice. Now PIP works on my Ubuntu 9.10. I want only add that i put all parameters from qemu to /etc/sysctl.conf:

    kernel.msgmnb=6553600
    kernel.msgmni=16
    kernel.msgmax=1048568

    And copy terminfo /usr/share/terminfo/v/vt420 to my system from qemu.

    Now works all perfectly.

    Regards,
    MJ

     

Log in to post a comment.