Can´t play "Error connecting to localhost"

Anonymous
2006-03-31
2013-03-05
  • Anonymous - 2006-03-31

    Hi, i cannot connect to any server neither to play local.  I become the message:

    Error connecting host ´localhost´: conexion rehusada

    I´ve opened the port 5556 by the firewall, but still doesn´t work.

    When i try to connect to a public game, I get:

    Connecting to localhost.localdomain, port 5556
    Cannot resolve localhost.localdomain port 5556: Nombre o servicio desconocido

    Any help out there? THANKS!

     
    • Bas Wijnen

      Bas Wijnen - 2006-03-31

      Hi,

      When you are behind a masquerading firewall, make sure that not only the port is open, but also that it's being forwarded to your machine.  Seeing your message this probably is not your problem though.

      Appearantly pioneers is unable to figure out your hostname (well, it does, but thinks it's "localhost.localdomain", which is not correct from an other computer).  This can be helped by reporting a better hostname to the meta-server.  In the field "reported hostname", you should fill in the name by which your computer can be reached (this may be an IP address).  In case of a masquerading firewall, it must be the name (or IP address) of the firewall.

       
      • Anonymous - 2006-04-01

        I don´t have any masquerading running with the firewall (so yast)
        I just don´t get something: if I want to play against the computer or other players on the net, it is the same procedure? Or are they two different things?
        Because, i try "Join public game", but there is no possibility to enter my hostname or local ip.

        Otherwise, when i try "Join private game" i gave as Server "localhost", my local IP, my remote IP, pebete.berlin (my computername), and nothing! Only when i give an IP, it says "connecting to port xx.xx.xx.xx and remains there till i break it. Then, it hangs :-(

         
        • Bas Wijnen

          Bas Wijnen - 2006-04-01

          Ah, sorry, I misunderstood your question.

          The procedure is always the same.  Someone must run a server, which will manage the game.  Then everyone (including the person running the server, if he wants to play) must start a client and connect to the server.

          To run the server, there are two options.  The first is to run a server on your own computer.  This can be done by selecting "Create game".  The settings window which then appears has the "reported hostname" field I mentioned above, but without masquerading you probably don't need it.  For a local game, you should set "register server" to "no", which makes the field irrelevant anyway.  When the settings are as you like them, select "start server".  Then your computer is running a server and waiting for clients.
          (Note: there is a bug when you start the server for the first time, the default settings will be useless.  Even if you want the settings you see, you must change them (victory point target and number of players) and change them back, otherwise they will be taken to be 0)

          The other option is to run a server on a meta-server.  When connecting to the meta-server (with "join public game"), there is a "new remote game" button.  If the meta-server allows this, it will be possible with that button to create a game on the meta-server.  The meta-server on pioneers.debian.net does not allow creation of games, though.

          When you have a server running, all clients must connect.

          Three scenarios:

          * You want to play a single player game against computer players:
          - Run pioneers
          - Select "Create game"
          - Set up the game, set "Register server" to "no"
          - Select "Start game"
          - Add number-of-players - 1 computer players
          - In the client, select "join private game"
          - fill in localhost and click OK

          * You want to play a multi-player game with some other people:
          - Run pioneers
          - Select "Create game"
          - Set up the game, set "Register server" to "yes"
          - Double check that the "Reported hostname" is something which all players can reach from their machine
          - Select "Start game"
          - If desired, add computer players
          - All players, in the client, select "join public game"
          - Select your game and click "Ok"

          * You want to play a multi-player game, but you don't have any other players yet:
          - Start pioneers
          - Select "Join public game"
          - Select the chatroom and click "Ok"
          (- Wait for other people to enter the chatroom)
          - Make arrangements for the game, and continue as in the above scenario.

          We are planning to make all this easier, but we didn't have time for that so far.

           
    • Roland Clobus

      Roland Clobus - 2006-04-01

      In the list of games on the public metaserver (Join public game) there are sometimes games that actually are not public (names like localhost, or localhost.localdomain, or other name that do not have at least 2 dots)

      If you just want to play against the computer, you can start a game with 'pioneers-server-gtk'. Add enough computer players, and join the game (Private game, host=localhost, port=the same as in the server [default=5556]).
      For such games, set 'Register Server' to 'No'.

       
  • Karen

    Karen - 2012-09-29

    I am having a similar problem and need some help.  My brother has set up the server on his end at his house and when I try to connect to his private game server from my house (on port 5556) it says error connecting to local host.  I know this is an issue on my end, possibly because I am charter communications cable internet and he is on at&t.  Everyone else is able to connect to his game server and they are on at&t.  We have tried different ports and still no go.  I can connect to the games on public pioneers.game-host.org that are not port 5556, but I can't connect to the games on pioneers.debian.net ( they all seem to be port 5556)  I have tried opening these ports (triggering I think its called) on my router configuration, My brother has  changed ports for me and I still can't connect.  Charter says they are not blocking anything but in my research there seems to be some indication that is not true.  Has anyone had this difficulty and have a possible solution (other than leaving charter and going back to at&t, (which I might actually do, I love this game)

     
  • Roland Clobus

    Roland Clobus - 2012-10-01

    Hello ksraber,
    You are describing two issues:
    1) Your brother is running the server, so _he_ will need to do the port forwarding in his router, not you. Furthermore he'll have to change the field 'Reported hostname' to his public IP-adress (e.g. by using something like http://whatismyipaddress.com). Then his game will be accessible from anywhere. Let me know it this helped or not. (There is no need to change providers)
    2) The games on pioneers.debian.net are often not publicly accessible, they are only announced. The person running the server has not set up port forwarding, so the game is visible, but nobody (except people in the local network) can connect to it.

     
  • Karen

    Karen - 2012-10-01

    Thankyou for the quick response.  I'm pretty sure he's done all that and I know he's done the port forwarding.  I'll forward your suggestions to him tho to see if it helps.  Its all a foreign language to me!

     

Log in to post a comment.