RJ Kyle - 2010-10-06

On some Linux distributions, like the latest Ubuntu, the pika executable cannot find the shared library. The directory CMake usually installs into is /usr/local/lib/, which sometimes is not part of the search path used when loading shared libraries.

There are a couple of thing you can do to fix this problem:
Let your system know about the directory:
What you need to do is open up /etc/ld.so.conf and add /usr/local/lib (or where ever libpika is) on a new line. Then run "sudo ldconfig" to update the cache.

Install to another directory:
Another option is to pass the install prefix used by your distribution to CMake using the CMAKE_INSTALL_PREFIX option. It needs to be done when you first invoke CMake.
For Example:
cmake path/to/pika -DCMAKE_INSTALL_PREFIX="/usr"

If you are still having trouble let me know.