#14 Upgrade path from v0.4 to v0.4a does not update method

v0.4
open
nobody
None
5
2009-04-06
2009-04-06
No

I upgraded to the latest v0.4a version today, and the plugin started getting errors from the last.fm server. I looked in the source to see if it was using the right method (because that's what it was complaining about) and it was. Then I realized that it must be saving the method name itself in preferences.

The last.fm plugin should verify on startup that the method is an acceptable one, or, preferably, it should not store the method name itself in preferences but rather a name for the selection itself. Future versions should also recognize old keys and update them to their reasonable alternatives or reset to the default.

Discussion


Log in to post a comment.