Problems compiling

Help
Eduardo
2003-09-09
2003-09-15
  • Eduardo

    Eduardo - 2003-09-09

    I cant finnish the make, my configure output is:
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc
    checking for gaim header files... ../../src
    checking for NSPR include files... /usr/include/mozilla/nspr
    checking for PR_GetError... yes
    checking for NSS include files... /usr/include/mozilla/nss
    checking for PK11_GenerateKeyPair... yes
    checking for pkg-config... /usr/bin/pkg-config
    checking for GTK+ - version >= 2.0.0... yes (version 2.2.2)
    checking for ld used by GCC... /usr/bin/ld
    checking if the linker (/usr/bin/ld) is GNU ld... yes
    checking for /usr/bin/ld option to reload object files... -r
    checking for BSD-compatible nm... /usr/bin/nm -B
    checking for a sed that does not truncate output... /bin/sed
    checking whether ln -s works... yes
    checking how to recognise dependent libraries... pass_all
    checking command to parse /usr/bin/nm -B output... ok
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking dlfcn.h usability... yes
    checking dlfcn.h presence... yes
    checking for dlfcn.h... yes
    checking for ranlib... ranlib
    checking for strip... strip
    checking for objdir... .libs
    checking for gcc option to produce PIC... -fPIC
    checking if gcc PIC flag -fPIC works... yes
    checking if gcc static flag -static works... no
    checking if gcc supports -c -o file.o... yes
    checking if gcc supports -c -o file.lo... yes
    checking if gcc supports -fno-rtti -fno-exceptions... yes
    checking whether the linker (/usr/bin/ld) supports shared libraries... yes
    checking how to hardcode library paths into programs... immediate
    checking whether stripping libraries is possible... yes
    checking dynamic linker characteristics... GNU/Linux ld.so
    checking if libtool supports shared libraries... yes
    checking whether to build shared libraries... yes
    checking whether to build static libraries... yes
    checking whether -lc should be explicitly linked in... no
    creating libtool
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating gaim-encryption-config.h
    config.status: gaim-encryption-config.h is unchanged
    config.status: executing depfiles commands

    And when I run make I have this error:
    keys.c: In function `GE_find_key_by_name':
    keys.c:64: parse error before `*'
    keys.c:65: `i' undeclared (first use in this function)
    keys.c:65: (Each undeclared identifier is reported only once
    keys.c:65: for each function it appears in.)
    keys.c:66: warning: control reaches end of non-void function
    make[1]: *** [keys.lo] Error 1
    make[1]: Leaving directory `/home/under/gaim-0.68/plugins/gaim-encryption-2.10'
    make: *** [all] Error 2

    I run a debian woody with gaim 0.68 ( I compiled it from source )
    many thanks.

     
    • Bill Tompkins

      Bill Tompkins - 2003-09-14

      Sorry, this is an error in the Gaim-Encryption source code, and doesn't compile with gcc 2.9.x

      Swap lines 63 and 64 in keys.c.  The function should look like:

      crypt_key * GE_find_key_by_name(key_ring *ring, char *name) {
         key_ring *i = GE_find_key_node_by_name(ring, name);
         gaim_debug(GAIM_DEBUG_MISC, "gaim-encryption", "find key by name: %s\n", name);
         return (i == NULL) ? NULL : ((key_ring_data *)i->data)->key;
      }

      I'll be releasing again soon to correct this- sorry about the bug.

      -Bill

       
    • Eduardo

      Eduardo - 2003-09-15

      I change that and now compile ok and works perfect with 1024 and 2048 keys.
      many thanks and congrats for the plugin.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks