Make problem

Help
Anonymous
2003-07-18
2003-07-28
  • Anonymous - 2003-07-18

    I have been unable to compile gaim with encryption since the change away from OpenSSL.  I am able to run the ./configure but during make I get the  error below.  This was with Gaim 0.65 and Encrypt 2.00.

    /usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -Wall  -DVERSION=\"0.65\" -DLOCALEDIR=\"/usr/local/share/locale\" -DLIBDIR=\"/usr/local/lib/gaim/\" -DDATADIR=\"/usr/local/share\"  -o encrypt.la -rpath /usr/local/lib/gaim -module -avoid-version encrypt.lo keys.lo prefs.lo keys_ui.lo config_ui.lo rsa_nss.lo nss_mgf1.lo nss_oaep.lo nss_pss.lo nonce.lo gpg.lo cryptproto.lo cryptutil.lo  -lnsl  -lcrypto -lnss3
    /usr/lib/gcc-lib/i486-suse-linux/3.3/../../../../i486-suse-linux/bin/ld: cannot find -lnss3

    I am running Suse 8.2 with Mozilla 1.4.  The includes are in /opt/mozilla/include/ which I define in the configure for nss and nspr.  There is one message during the configure which may or may not be relevent.

    checking for NSPR includes... /opt/mozilla/include/nspr/
    checking for NSS includes... /opt/mozilla/include/nss/
    checking for nss.h... yes
    checking for nssbase.h... yes
    checking for keyhi.h... yes
    checking for PK11_GenerateKeyPair in -lnss3... no

     
    • Anonymous - 2003-07-18

      I also get the exact same error when trying to build.  I can get through configure(it detects nss and nspr) but it dies on make.  I am running Redhat 9 btw.

      -Graham

       
      • Bill Tompkins

        Bill Tompkins - 2003-07-18

        First figure out where your nss (and nspr) libraries get installed.  Not the header files, but the libraries: libnss3.a or libnss3.so, for example.

        If they're in /usr/local/lib, then run configure with the option:
        configure --with-nspr-libs="/usr/local/lib"

        Also, if you post here with the location of your libs, I'll work on making an autodetector for the configure script.

         
    • Justin Mazzi

      Justin Mazzi - 2003-07-19

      i have done this and the build still fails. my libraries are in /usr/local/lib

       
    • Anonymous - 2003-07-28

      i've tried endlessly to get through the configure process, but nothing ever works. it either gives an error about it not being able to find the libraries or includes, or it says Permission Denied. i have no idea why i don't have permission if i'm compiling this as root.

      anyone else had this?

       
      • Bill Tompkins

        Bill Tompkins - 2003-07-28

        I don't know where or why you'd get a message saying "Permission Denied".  Things that would be useful to know to diagnose your problem:
        1) The location of your NSS and NSPR includes and lib files
        2) The error message you get from running configure
        3) The OS/distribution that you're using.

         
      • Anonymous - 2003-07-28

        to be more specific in order to help anyone else with my situation;

        checking for NSPR includes... /usr/include/mozilla/nspr
        checking for NSS includes... /usr/include/mozilla/nss
        checking nss.h usability... yes
        checking nss.h presence... yes
        checking for nss.h... yes
        checking nssbase.h usability... yes
        checking nssbase.h presence... yes
        checking for nssbase.h... yes
        checking keyhi.h usability... yes
        checking keyhi.h presence... yes
        checking for keyhi.h... yes
        configure: error: Need to specify location of NSS and NSPR includes
        leetbox:/home/grind/gaim#

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks