Gaim crashes upon enabling of encryption

Help
Anonymous
2004-01-13
2004-03-24
  • Anonymous - 2004-01-13

    I have installed the latest version of the software. Going to check the box next to its name in my Preferences, Gaim crashes in the process. Any ideas?

     
    • Christopher N. Deckard

      I see this same problem.  Anyone know how to fix it?  This is the first time I've tried the plugin, and it seems to crash after it can't open id.priv.

       
    • Bill Tompkins

      Bill Tompkins - 2004-01-16

      If "latest version" was 2.19 on Windows, try 2.21.  2.19 had a conflict with the version of the NSS libraries that Gaim 0.75 shipped with.

       
    • Fergus Geebly

      Fergus Geebly - 2004-01-28

      i'm having this same problem.  i'm running on Fedora Core 1 with the default libraries for mozilla 1.4 installed (mozilla, mozilla-nspr, mozilla-nspr-devel, mozilla-nss, mozilla-nss-devel).  i've compiled and installed gaim-0.75 and compiled and installed gaim-encryption-2.21.  Running gaim-encryption's configure with no special arguments seems to find the defaul mozilla 1.4 libraries and headers just fine, and the plug-in shows up in gaim 0.75.  When i click to enable the plug-in, i get the following (with debugging turned on):

      gaim-encryption: Checking for old prefs file (/home/geebly/.gaim/encrypt.prefs)...
      gaim-encryption: plugin_load called
      gaim-encryption: Couldn't open file:/home/geebly/.gaim/id
      Error opening file: No such file or directory
      gaim-encryption: Couldn't open file:/home/geebly/.gaim/id.priv
      Error opening file: No such file or directory
      gaim-encryption: find key by name: geeblyaimlogin
      gaim-encryption: find key by name: geeblyaimlogin
      gaim-encryption: Could not generate key.  NSS Error: -8128

      i've put all of the gaim libraries in my ld_library_path and i've put all of the mozilla-1.4 libraries in as well.  i've tried running config with the library and include paths specifically set as the INSTALL doc says, and i continually get this same problem.  Can anyone tell me what i'm missing?
      Thanks.

       
    • Fergus Geebly

      Fergus Geebly - 2004-01-28

      Well, i found out what my problem was, kind of.  i've been compiling and installing gaim as myself (non-root).  i like to do this with a lot of applications that i ... uh ... don't always entirely trust, nothing against gaim and gaim-encryption.  Anyway, i su'd to root, compiled, and installed.  Apparently gaim-encryption wants gaim to have setuid-root privs or something, cuz after installing as root, gaim-encryption seems to be working... well, its not crashing/dying on me.  Now i need to test it out with someone else running the plug-in.  Sorry for the board-noise.

       
      • Bill Tompkins

        Bill Tompkins - 2004-02-01

        No offense taken :)

        There's no suid code in the plugin.  That error log shows an error NSS library- maybe compiling as root you linked against a different version of the library?

        Definitely seems a little strange.  I tend to compile as self, install as root.  But I've chowned the /usr/local/gaim directory to self before, and done the whole process as self with no issues.

        Thanks for posting what worked for you, though,

        -Bill

         
    • Antonio Musumeci

      The error is SEC_ERROR_NO_MODULE from secerr.h of nss i blieve, havent tracked down what that means yet though.

       
    • Ryan Carter

      Ryan Carter - 2004-02-02

      I had the same issue as geebly and it was only fixed by su'n to root and compiling/installing just as geebly did.

       
      • Binesh Bannerjee

        Add me to the list... Strange... I don't see any EPERM or anything like that...

         
        • Binesh Bannerjee

          (In my case, simply su'ing to root causes gaim to work...) It's odd, like I said, because strace'ing the processes shows no EPERM's... However, I dunno, if this is a clue or not, BUT, the user one looks for "ca.pem" and ENOENT's on it (and the root one, doesn't EVEN look for that... (so of course, it doesn't ENOENT, but, it simply never tried to openit... Maybe I'll try rolling back to an older version to see if it's something new introduced... (I just started trying gaim-encrypt)

           
          • Binesh Bannerjee

            I'm pretty sure I know what it is... I created another account, with a clear text home directory (My directories are encrypted with CFS, which is a NFS based encrypted file system)... and it works... So, I'm curious now, as to whether the other folks also had NFS mounted  homedrives. I guess I should figure out what's causing that to fail now... (Sorry for the blog like nature of my posts.)

             
            • Binesh Bannerjee

              No... I think the root making it work, and the other user making it work was a red herring.. The minute that I added users to the gaims on the other accounts, I got the -8128 (SEC_ERROR_NO_MODULE) errors again....

              OK... Now I'm giving up... Well... at least for tonight... OK... maybe, maybe not...

               
              • Binesh Bannerjee

                OK... I have this one figured out...

                here's what happens: When mozilla is installed from source, it puts it's libs in /usr/local/lib/mozilla-1.x/libwhatever.so

                Well, in
                plugins/ssl/ssl-nss.c:61 of gaim-0.75
                It tries to
                    SECMOD_AddNewModule("Builtins",LIBDIR "/libnssckbi.so");

                And, LIBDIR (in my case) is /usr/local/lib.

                doing
                    ln -s /usr/local/lib/mozilla-1.6/libnssckbi.so /usr/local/lib/libnssckbi.so

                caused it to stop coring... To REALLY get it to work tho, required one more change to gaim-encryption itself tho

                keys.c:359 of gaim-encryption-2.22
                if (chmod(path, S_IWUSR) == -1) {

                causes the known keys file to be write only, which causes

                keys.c:367 of gaim-encryption-2.22
                fd = open(path, O_RDWR | O_CREAT, S_IRUSR | S_IWUSR);

                to fail.

                if you just change the chmod to chmod(path,0600)

                that solves that. I'll send a patch to Bill Tompkins

                 

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks