Compiling 2.27 with gaim 0.79 RH9 pkg

Help
2004-06-29
2004-07-11
  • Thomas Fischer

    Thomas Fischer - 2004-06-29

    I am trying to compile the gaim-encryption plugin v2.27 with a stock install of gaim 0.79 RH9 rpm package.
    Gaim-encryption configure script fails requesting the PKG_CONFIG_PATH for gaim.pc. However this file doesn exist in the RPM package.
    I also tried to compile the plugin inside the gaim source directories and still get the same issue.
    Trying the suggestion in the INSTALL read me did not help either.
    How do I get the plugin to compile?
    Thnks

     
    • Anonymous - 2004-07-01

      I have a very similar problem, only I'm on solaris and I built gaim and then tried to build this plugin.  The gaim source does not create the .pc file, I was wonder if someone could tell me what the contents of the file is supposed to be.

       
    • Anonymous - 2004-07-01

      I figured out my problem... I was in the wrong directory and compiling an older version of gaim.

      You should download the latest version and just run the ./configure script.  It will build a gaim.pc file for you and then you can put that in your lib/pkgconfig path.

      -Erik

       
    • Thomas Fischer

      Thomas Fischer - 2004-07-02

      This didn't work either.. The header files continued to look for files and could not find them. I had to end up modifying the Makefile to include the source code trees...

      I think a more coordinate check needs to be made between the gaim package releases and the gaim-encryption plugin.

      Or create a Make file with a switch to use the gaim source code tree as include paths (i.e. the old way the make was run).

       
    • Bill Tompkins

      Bill Tompkins - 2004-07-11

      The "gaim-devel-0.79-0rh9.i386.rpm" RPM contains the .pc file, and the necessary headers to compile Gaim-Encryption.  Sorry that this was unclear from the install instructions.

      If you compile Gaim from source, install it, and specify the location of the .pc file when ./configure-ing Gaim-Encryption (as specified in the install instructions) that will work too.

      -Bill

       

Log in to post a comment.