Received pub keys are not cacheing. (Linux)

Help
2004-01-30
2004-02-02
  • Fergus Geebly

    Fergus Geebly - 2004-01-30

    i compiled and am running on a basic install of Fedora Core 1.
    i notice that every time i restart Gaim my list of known keys only has my key in it.  As i start sessions with folks, public keys appear in the list as i get "requesting key" messages.  Restarting Gaim clears that list again.

    Is this expected behaviour?  i'm thinking it isn't but haven't confirmed that anywhere.

    Thanks for any help.

     
    • Bill Tompkins

      Bill Tompkins - 2004-02-01

      There are two lists of "known" keys:

      One is an in-memory cache, that is shown if you go to Tools->Preferences->Plugins->Gaim-Encryption, where you can re-generate private keys, etc.  Private keys are automatically loaded into this cache on startup, but other user's public keys are only loaded as they are received (and accepted) each session.

      The other is the .gaim/known_keys file, which saves all of the keys you have "accept-and-save"d when you get that dialog on conversation startup.  Once a key is present in that file, it should be automatically accepted (ie. no popup) when received on a conversation start.  If your buddy changes their key, though, you would then get the "Conflicting key" popup.

      This lets the plugin do things like "accept a key this one time": it then goes into the cache in memory, but not into the file.

      I realize that this behavior might not be intuitive, and that there is no label on the key list in the Preferences box.  That's something that I should probably add (together with a help button).  Alternatively, the window could be a view into the known_keys file, rather than the in-memory cache.  Then, though, you couldn't see the key fingerprint of those keys you haven't trusted enough to save.

      Make sense?

       
    • Fergus Geebly

      Fergus Geebly - 2004-02-02

      Makes perfect sense.  Thanks for the explanation.

      Based on your comments, i thought at first maybe keys weren't being saved because i had the "Accept key automatically if no key on file" option selected.  My thought was since i didn't get the dialogue box, i couldn't choose to save them for next time.  Unselecting this option didn't seemt to make any difference.

      Then i noticed that the file permissions on the default known_keys file created were not readable or writable by anyone.  Changing permissions on that file and manually accepting/saving keys now has keys showing up in that file.  (Though i have not gone back and tested it with the Automatic Accept to see if that really had anything to do with it.)

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks