Gaim-Encryption for Gaim 2.0.2b4?

Eric
2006-10-18
2013-04-22
  • Eric

    Eric - 2006-10-18

    Do you have an ETA for release of Gaim-Encryption for the new Gaim release?

    Thanks.

     
    • Eric

      Eric - 2006-10-18

      Correction: that's Gaim 2.0.0b4 ...fat fingered it. :)

       
    • bbilut

      bbilut - 2006-10-19

      I was hoping the currently version of encyrption would work with the latest Beta 4 of Gaim, but I guess not. :-(

       
      • Eric

        Eric - 2006-10-19

        It might be, but just not be shoing up in 2.0.0b4 plugin list. Can you try bumping and recompiling the version number of Gaim that the plugin is compatible with so it shows up in the list? Similar to how you make older extensions work with newer (unsupported) versions of Mozilla?

         
    • hjheins

      hjheins - 2006-10-23

      Thanks for your fixes on gaim-encryption for Gaim 2.0beta4!
      They seem to work just fine; I just downloaded from cvs and build a Debian version ( http://hjh.passys.nl/Debian/Sid ).

      One question: I noticed something about the log you changed in state-ui.c What does that do/mean? Are the logs encrypted as well?

       
      • Bill Tompkins

        Bill Tompkins - 2006-10-25

        re: log encryption - that is so that when you view the log, you can see which messages were sent encrypted.

        -Bill

         
    • Kevin J. Slater

      Kevin J. Slater - 2006-10-24

      what's the build environment for Windows? (I mean, what compiler, etc.) I'd like to try to build the latest with the version change to see if it'll work with the Windows 2.0beta4 release..

      ...Kevin

       
    • Bill Tompkins

      Bill Tompkins - 2006-10-25

      Just posted 3.0b6 as source. I'll try to get out a Win32 build as soon as I can, but currently have a nasty cold, so I'm heading to bed.

      Kevin- the Windows build environment is the same as the Gaim windows build environment.  If you get Gaim building, then unpack Gaim-Encryption in the plugins directory, it should build (using make -f Makefile.mingw).  Then again... I think that some of the Windows build infrastructure might have moved around between Gaim 2.0b3 and 2.0b4, so it might not build out of the box.

      -Bill

       
    • hjheins

      hjheins - 2006-10-25

      aaah, that's a nice feature!
      I'll post a new build based on this stable version soon; same location.

      Get well soon!

      Hendrik-Jan

       
    • John Shute

      John Shute - 2006-10-25

      Bump....

      Any ETA on the posting of the binary of Gaim-Encryption 3.0Beta6?

      Looked at building it, but could not find a clear set of instructions (already looked at http://gaim-encryption.sourceforge.net/win32.php\).

      Thanks,
      John

       
    • morbo

      morbo - 2006-10-25

      I would greatly appreciate if someone would post a windows version of the Encryption plugin for
      Gaim 2.0.0b4! I looked into compiling it myself, but I didn't get too far.

      Thanks!

       
      • Eric

        Eric - 2006-10-25

        I'm sure Bill will post one soon and he's the official developer. You can revert to Gaim 2.0b3.1 like I did in the meantime. Crypto is something you should think about what source you're getting it from especially for precompiled code.

         
        • morbo

          morbo - 2006-10-25

          Thanks for the update.
          I would hope to download the precompilied code from:
          http://gaim-encryption.sourceforge.net/
          Wouldn't that be the offical/safe place to get it from?

           
          • Eric

            Eric - 2006-10-25

            Yes, that's the project's official site on SourceForge.

             
    • Web Guy

      Web Guy - 2006-10-26

      I tried to compile it - got close but not quite.  The paths are definitely out of whack.  Look forward to a more knowledgeable mind providing insight as well.

       
    • Bill Tompkins

      Bill Tompkins - 2006-10-26

      Win32 binary posted.

      For those interested in compiling Win32 from source, the Makefile.mingw is now fixed up (in CVS) to build properly if Gaim-Encryption is put in the gtk/plugins directory of the Gaim distribution.

      -Bill

       
    • Web Guy

      Web Guy - 2006-10-26

      Thanks Kindly, Bill.  Gaim-encryption rocks.

       
      • morbo

        morbo - 2006-10-26

        Yes! Thank you very much Bill!
        Very much appreciated.
        Great job by the way!
        BB

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks