Glad I have months (years) of PhpWiki-talk email. I installed RC3 on my Fedora Core 3 Linux box here at work today. I was stumped trying to get around the "Cannot redeclare class pear" error! Switching to ADODB solved it.

[client 192.168.2.208] PHP Fatal error:  Cannot redeclare class pear in /home/swain/public_html/phpwiki-1.3.11/lib/pear/PEAR.php on line 74

Otherwise installation was pretty simple. Note that "lock tables" in the GRANT statement in INSTALL.mysql was not legal in my older copy of Mysql (3.23.58). 

I also got:
[client 192.168.2.208] PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted (tried to allocate 138 bytes) in Unknown on line 0

when loading the new pages for the first time. Repeatedly reloading the page eventually got them all loaded.

It looks beautiful. You've all doing a great job!

~swain

On Apr 15, 2005, at 9:57 AM, Yannick Lefebvre wrote:

I have switched over to ADODB and the error went away. I am now able to run 1.3.11 on IIS 6.0/MySQL. Looking good.
 
Yannick
-----Original Message-----
From: Yannick Lefebvre
Sent: Thursday, April 14, 2005 4:43 PM
To: 'phpwiki-talk@lists.sourceforge.net'
Subject: RE: Phpwiki 1.3.11 on IIS 6.0/MySQL

After searching through the forums on the Sourceforge site, I found that I need to remove the if statement on line 55 of Index.php if I get an empty page. I have done that and now get:
 
 Fatal error: Cannot redeclare class pear in D:\WWW\INTRANET\phpwiki\lib\pear\PEAR.php on line 74 
 
Yannick
-----Original Message-----
From: Yannick Lefebvre
Sent: Thursday, April 14, 2005 3:18 PM
To: phpwiki-talk@lists.sourceforge.net
Subject: Phpwiki 1.3.11 on IIS 6.0/MySQL

Hello,
 
I was able to run Phpwiki 1.2 on our IIS 6.0 server with MySQL database. However, I'm having trouble with version 1.3.11. If I don't specify an admin user name and password, I get the message:
 
Fatal error: Cannot redeclare _http_user() (previously declared in D:\WWW\INTRANET\phpwiki\configurator.php:71) in D:\WWW\INTRANET\phpwiki\configurator.php on line 70
 
If I set these parameters inside of the config file (encrypting the password through the utility), I just get a blank page at the base of the wiki.
 
Has someone been able to get phpwiki to run on a similar configuration? Thanks for any help you can provide,
 
Yannick
 
______________________________________
Yannick Lefebvre
eNGENUITY Technologies Inc
Senior Technical Specialist
Spécialiste Technique Sénior
Tel: (514) 341-3874 Ext. 268
Fax: (514) 341-8018
yannick.lefebvre@engenuitytech.com
www.engenuitytech.com
4700 de la Savane, # 300
Montréal, Québec H4P 1T7 Canada
______________________________________
Visual. Software. Solutions.