PHPWiki - PHP Warnings and fatal errors on default setup

Help
2013-12-05
2015-09-04
  • Keith Ayers

    Keith Ayers - 2013-12-05

    Hi everyone,

    This is my first time using SourceForge, but I'll try to provide any information you could need.

    I'm having a problem with PHPWiki out of the box - I've set this up on a web server (Windows Server 2012 R2) with a SQL Server backend (SQL Server 2012) with PHP installed (5.3.x). After copying the files, verifying permissions, creating the database, setting up the schema, and configuring the config.ini a few times, I get a working wiki that has all kinds of bugs on it. Many PHP warnings, but a couple of fatal errors. See the images below for details:

    My PHPWiki home page

    My PHPWiki All Pages page

    (Also notice the top link on the toolbox on the left-hand side. No idea what's going on there either)

    I've been scouring the internet, but to no avail. What am I missing? I've also included my config.ini in a link below (with the Admin username, password, and dsn changed, I don't think that's the problem).

    https://dl.dropboxusercontent.com/u/767534/etc/config.ini

    Can anyone help me? I can verify settings/configuration if you need more info.

    Thanks in advance,

    • Keith
     
  • Rune Thorsen

    Rune Thorsen - 2015-09-03

    I can't get started either, using XAMPP on Win7. I do not understand to unbox and get running.
    I have also tried the configurator.php but it results in
    Call to a member function fetch() on a non-object in C:....\phpwiki-1.5.4\lib\WikiUser\PdoDb.php on line 71

     
  • Marc-Etienne Vargenau

    Hi,

    PDO is not fully tested.

    Try replacing

    DATABASE_TYPE = PDO

    with

    DATABASE_TYPE = SQL

    in your config/config.ini file

    Best regards,

    Marc-Etienne Vargenau

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks