#1801 Menus in 1.3.1 disapeared

phpws1.x
closed-fixed
None
5
2007-10-03
2007-09-17
LionsCub
No

Linux host.data-web.us 2.6.9-42.0.3.ELsmp #1

Apache/1.3.33 (Unix)
mod_auth_passthrough/1.8
mod_log_bytes/1.2
mod_bwlimited/1.4
PHP/4.3.11
FrontPage/5.0.2.2635
mod_ssl/2.8.22
OpenSSL/0.9.7a

Ok just boosted the latest modules here is my current list.
Core 1.6.1
Boost 2.1.3
Categories 2.1.9
Clipboard 1.0.0
Comments 0.6.4
Control Panel 2.1.2
Demographics 1.0.0
File Cabinet 1.2.1
Layout 2.4.2
MiniAdmin 1.1.1
Notes 0.2.0
Search 0.2.3
Users 2.4.2
Version 0.1.5
Access 0.2.3
Block 1.1.3
Blog 1.6.0
Branch 1.1.2
Breadcrumb 2.0.0
Calendar 1.5.2
Menu 1.4.0
PageSmith 1.0.2
Form Generator 3.1.0
Photo Album 1.4.2
Profiler 0.3.2
Related 0.1.5
RSSFeeds 0.2.1
Signup 1.0.1
Skeleton 0.0.1
Web Pages 0.5.5
Whodis? 0.1.1

My menu completely disapeared. I had a horizontal menu and so I tried to go into the menu module through control panel and got the following errors.

Warning: Invalid argument supplied for foreach() in /home/rampantl/public_html/website/mod/menu/class/Menu_Item.php on line 89

The above warning displayed across the top of my page. And the following error displayed inside the control panel.

Template Cannot locate any menu templates. Cannot continue.

Discussion

  • LionsCub

    LionsCub - 2007-09-17

    Logged In: YES
    user_id=1872751
    Originator: YES

    I found my menus, I had to go in and delete my themes custom menus. The structure of the template>menu directory changed and since my theme had custom menu templates that did not match the new directory structure it caused the error.

     
  • Anonymous

    Anonymous - 2007-09-18

    Logged In: YES
    user_id=400519
    Originator: NO

    The last issue will be a little hurtle. I changed the menu templating scheme to allow a little more flexibility of design. Unfortunately, after updating the files, Menu still gets to run prior to going to Boost.

    The fix is to go to the edit menu screen and update it.

    I am going to edit that file to prevent that error in any case. I am pending this for close. You can set to open if further discussion is needed.

     
  • Anonymous

    Anonymous - 2007-09-18
    • assigned_to: nobody --> stardog
    • status: open --> pending-fixed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending-fixed --> closed-fixed
     

Log in to post a comment.