Mounted Filesystems not showing (3.0.4)

Help
Jim!
2010-02-23
2012-12-12
  • Jim!

    Jim! - 2010-02-23

    I have just installed phpsysinfo and none of my Filesystems are showing up.

    Here is the output from df -k

    $ df -k
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /dev/sda1              8062888   4616440   3036876  61% /
    tmpfs                  1030400        12   1030388   1% /lib/init/rw
    udev                     10240       228     10012   3% /dev
    tmpfs                  1030400         4   1030396   1% /dev/shm
    /dev/sda6             76046288  50859480  25186808  67% /home
    

    And the xml.php

    <tns:phpsysinfo xsi:schemaLocation="http://phpsysinfo.sourceforge.net/ phpsysinfo3.xsd">
    <Generation version="3.0.4" timestamp="1266957717"/>
    <Options tempFormat="c" byteFormat="auto_binary" refresh="60000" showPickListTemplate="true" showPickListLang="true"/>
    <UsedPlugins/>
    <Vitals Hostname="localhost" IPAddr="192.168.0.10" Kernel="2.6.31.12-174.2.22.fc12.x86_64 (SMP) x86_64" Distro="Fedora release 12 (Constantine)" Distroicon="Fedora.png" Uptime="21862.62" Users="3" LoadAvg="0.11 0.12 0.11" CPULoad="0"/>
    
    <Network>
    <NetDevice Name="lo" RxBytes="11171983" TxBytes="11171983" Err="0" Drops="0"/>
    <NetDevice Name="eth0" RxBytes="45208385" TxBytes="186899602" Err="0" Drops="0"/>
    <NetDevice Name="tun0" RxBytes="0" TxBytes="0" Err="0" Drops="0"/>
    </Network>
    
    <Hardware>
    
    <PCI>
    <Device Name="Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge" Count="6"/>
    <Device Name="PIC: VIA Technologies, Inc. K8M890CE I/O APIC Interrupt Controller" Count="1"/>
    <Device Name="PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]" Count="1"/>
    <Device Name="PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller" Count="2"/>
    <Device Name="IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller" Count="1"/>
    <Device Name="IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE" Count="1"/>
    <Device Name="USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller" Count="4"/>
    <Device Name="USB Controller: VIA Technologies, Inc. USB 2.0" Count="1"/>
    <Device Name="ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge" Count="1"/>
    <Device Name="Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller" Count="1"/>
    <Device Name="Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II]" Count="1"/>
    <Device Name="Host bridge: VIA Technologies, Inc. VT8237A Host Bridge" Count="1"/>
    <Device Name="PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge" Count="1"/>
    <Device Name="Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration" Count="1"/>
    <Device Name="Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map" Count="1"/>
    <Device Name="Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller" Count="1"/>
    <Device Name="Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control" Count="1"/>
    <Device Name="VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE]" Count="1"/>
    <Device Name="Communication controller: NetMos Technology PCI 9835 Multi-I/O Controller" Count="1"/>
    <Device Name="Communication controller: Conexant Systems, Inc. HSF 56k Data/Fax/Voice Modem" Count="1"/>
    <Device Name="Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC]" Count="1"/>
    </PCI>
    
    <USB>
    <Device Name="Linux Foundation 2.0 root hub" Count="1"/>
    <Device Name="Linux Foundation 1.1 root hub" Count="4"/>
    <Device Name="Logitech, Inc. LX-700 Cordless Desktop Receiver" Count="1"/>
    </USB>
    <IDE/>
    
    <SCSI>
    <Device Name="ATA      SAMSUNG HD103SJ  (Direct-Access)" Count="1"/>
    <Device Name="PHILIPS  SPD6005T         (CD-ROM)" Count="1"/>
    <Device Name="ATA      WDC WD5000AAKB-0 (Direct-Access)" Count="1"/>
    </SCSI>
    
    <CPU>
    <CpuCore Model="AMD Athlon(tm) 64 X2 Dual Core Processor 3600+" CpuSpeed="1999.986" Cache="262144" Bogomips="3999.97" Load="0.49751243781095"/>
    <CpuCore Model="AMD Athlon(tm) 64 X2 Dual Core Processor 3600+" CpuSpeed="1999.986" Cache="262144" Bogomips="3999.75" Load="0"/>
    </CPU>
    </Hardware>
    
    <Memory Free="317915136" Used="1789358080" Total="2107273216" Percent="85">
    <Details App="891138048" AppPercent="43" Buffers="200355840" BuffersPercent="10" Cached="697864192" CachedPercent="34"/>
    
    <Swap Free="8471994368" Used="0" Total="8471994368" Percent="0">
    <Mount MountPointID="1" FSType="" Name="SWAP" Free="8471994368" Used="0" Total="8471994368" Percent="0" MountPoint="/dev/sdb7"/>
    </Swap>
    </Memory>
    <FileSystem/>
    
    <MBInfo>
    
    <Temperature>
    <Item Label="Core0 Temp" Value="35.0" Max="75"/>
    <Item Label="Core1 Temp" Value="33.0" Max="75"/>
    <Item Label="temp1" Value="33.0" Max="75"/>
    <Item Label="temp2" Value="37.0" Max="120.0"/>
    <Item Label="temp3" Value="39.0" Max="80.0"/>
    <Item Label="/dev/sda (SAMSUNG HD103SJ)" Value="36" Max="60"/>
    <Item Label="/dev/sdb (WDC WD5000AAKB-00YSA0)" Value="42" Max="60"/>
    </Temperature>
    
    <Fans>
    <Item Label="fan1" Value="1171" Min="0"/>
    <Item Label="fan2" Value="0" Min="3515"/>
    <Item Label="fan3" Value="0" Min="0"/>
    <Item Label="fan5" Value="0" Min="0"/>
    </Fans>
    
    <Voltage>
    <Item Label="Vcore" Value="1.29" Min="0.00" Max="1.74"/>
    <Item Label="in1" Value="1.85" Min="1.53" Max="1.53"/>
    <Item Label="AVCC" Value="3.26" Min="2.98" Max="3.63"/>
    <Item Label="VCC" Value="3.28" Min="2.98" Max="3.63"/>
    <Item Label="in4" Value="1.96" Min="1.75" Max="1.91"/>
    <Item Label="in5" Value="1.91" Min="1.02" Max="1.02"/>
    <Item Label="in6" Value="1.96" Min="2.04" Max="2.04"/>
    <Item Label="3VSB" Value="3.25" Min="2.98" Max="3.63"/>
    <Item Label="Vbat" Value="3.12" Min="2.70" Max="3.30"/>
    <Item Label="in9" Value="1.62" Min="2.04" Max="2.04"/>
    <Item Label="cpu0_vid" Value="0.375" Min="0" Max="0"/>
    </Voltage>
    </MBInfo>
    <UPSInfo/>
    <Plugins/>
    <Errors/>
    </tns:phpsysinfo>
    

    Hope you can help!

    Jim!

     
  • Jim!

    Jim! - 2010-02-23

    Here's the picture;


    Jim!

     
  • Jim!

    Jim! - 2010-02-24

    I really should stop replying to my own messages;

    Changing define('PSI_SHOW_MOUNT_OPTION', true); to define('PSI_SHOW_MOUNT_OPTION', false); makes absolutely no difference.

    Jim!

     
  • Erkan

    Erkan - 2010-02-24

    Hello,

    Thanks for the report. Can you also paste here the output of "mount" command please?

    Regards

     
  • Otusfi

    Otusfi - 2010-02-24

    I have the same problem, had it with 3.0.3 too. Before that i had RC8 i think and with that it worked fine

     
  • Jim!

    Jim! - 2010-02-24

    As requested, output from "mount";

    As User

    $ mount
    /dev/sda2 on / type ext4 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    tmpfs on /dev/shm type tmpfs (rw)
    /dev/sda1 on /boot type ext4 (rw)
    /dev/sda3 on /var/hda type ext4 (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
    gvfs-fuse-daemon on /home/jiml/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=jiml)
    

    As root;

    # mount
    /dev/sda1 on / type ext4 (rw,noatime,errors=remount-ro,barrier=0)
    tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    udev on /dev type tmpfs (rw,mode=0755)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
    /dev/sda6 on /home type ext3 (rw,noatime)
    fusectl on /sys/fs/fuse/connections type fusectl (rw)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    

    Jim!

     
  • Jim!

    Jim! - 2010-02-24

    Ignore the second one I put it in because there seemed to be a discrepency. Well there would be, I hadn't ssh into the right box yet. It's really annoying how you can't go back and edit a message on here.

    Jim!

     
  • Erkan

    Erkan - 2010-02-25

    Hello,

    Did you try to add some path in PSI_ADD_PATHS ?

    $> vim config.php
    define('PSI_ADD_PATHS', '/bin, /usr/bin');

    $> whereis mount
    $> whereis df

     
  • Jim!

    Jim! - 2010-02-27

    Both mount and df are in /bin directory. I added the path as suggested and nothing changed.

    However after an update it automagically started working. So was it just the paths and a service restart which occurred during the update or a combination of both? (rhetorical)

    I have removed the paths and it still seems to be working, are there any services I need to restart to see if it was the paths as suggested.

    Jim!

     
  • Otusfi

    Otusfi - 2010-02-27

    I noticed my phpsysinfo gets stuck trying to read my .gvfs folder in my home folder. is there any way i can make phpsysinfo to exluded it?

     
  • Erkan

    Erkan - 2010-02-27

    Hello,

    Is 'mount' command also stuck?

     
  • Otusfi

    Otusfi - 2010-02-28

    no, it gets stuck only on the .gvfs folder, if i remove it then the script will run fine and show the filsesystems but the folder reappears on every boot.

     
  • Jim!

    Jim! - 2010-03-03

    Anyway, as I was saying before this thread was hijacked;

    Both mount and df are in /bin directory. I added the path as suggested and nothing changed.

    However after an update it automagically started working. So was it just the paths and a service restart which occurred during the update or a combination of both? (rhetorical)

    I have removed the paths and it still seems to be working, are there any services I need to restart to see if it was the paths as suggested.

    Jim!

     
  • Lionel F. Lebeau

    Same problem here.

    As user (not root) :

    df -k
    Sys. de fich.        1K-blocs       Occupé Disponible Capacité Monté sur
    /dev/mapper/vg_serv2-lv_root                  129441412  73223220  49642884  60% /
    tmpfs                  6195428       272   6195156   1% /dev/shm
    /dev/sda1               495844     64279    405965  14% /boot
    

    With DEBUG true I get this :

    /bin/df
    /bin/df: `/home/Pulsar-san/.gvfs': Permission denied
    Return value: 1
    ./xml.php on line 45
    ./includes/output/class.WebpageXML.inc.php on line 138 in function run()
    ./includes/xml/class.XML.inc.php on line 449 in function getXml()
    ./includes/xml/class.XML.inc.php on line 428 in function _buildXml()
    ./includes/os/class.OS.inc.php on line 70 in function getSys()
    ./includes/os/class.Linux.inc.php on line 561 in function build()
    ./includes/os/class.Linux.inc.php on line 482 in function _filesystems()
    ./includes/class.Parser.inc.php on line 90 in function df( "-P" )
    ./includes/class.CommonFunctions.inc.php on line 123 in function executeProgram( "df", "-k -P", "Filesystem         1024-blocks      Used Available Capacity Mounted on\n/dev/mapper/vg_serv2-lv_root 129441412  73208780  49657324      60% /\ntmpfs                  6195428       272   6195156       1% /dev/shm\n/dev/sda1               495844     64279    405965      14% /boot", true )
    
     
  • Lionel F. Lebeau

    Really miss Preview and Edit…

    As you can see, the last line shows what should be displayed.
    I think it is just a problem with error handling.

     
  • Lionel F. Lebeau

    OK, I found the solution.
    In "includes/class.CommonFunctions.inc.php" comment the "return false" in function "executeProgram" :

    if (! empty($strError) && $return_value <> 0) {
                if ($booErrorRep) {
                    $error->addError($strProgram, $strError."\nReturn value: ".$return_value);
                }
                //return false;
            }
    
     
  • Erkan

    Erkan - 2010-03-06

    Hello,

    Thanks for the report. 'df' return 1 because permission denied so PhpSysInfo break…but output is ok.

    /bin/df: `/home/Pulsar-san/.gvfs': Permission denied Return value: 1
    

    You fix works in this case. I will commit a patch soon.

     
  • Alex.inf

    Alex.inf - 2010-10-05

    pulsar-san
    Thx!
    I'm good at php but it tooks me about an hour to solve this problem.
    I had an older version of PSI (not 3.0.5 but not the second one). It worked fine.
    After update to 3.0.5 PhpSysInfo starts to write No matching records found in the box of Mounted Filesystems.
    and older PSI always writes Permission denied where it needs.
    I have out put of df -h like this:

    alex@router_a ~ $ df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda3              14G  5.4G  7.7G  42% /
    udev                   10M  200K  9.9M   2% /dev
    /dev/sda5              14G  2.5G   11G  19% /var
    /dev/sda6              23G   13G  9.3G  58% /home
    /dev/sda7              47G   14G   33G  30% /var/www/localhost/htdocs/pg
    /dev/sda8              51G  201M   51G   1% /mnt/samba
    df: `/home/ftp/private/films': Permission denied
    df: `/home/ftp/private/files': Permission denied
    /dev/sdd1             112G   89G   24G  80% /home/alex/hdd_120
    df: `/home/ftp/private/video': Permission denied
    /dev/sdf1              56G   43G   14G  76% /home/ftp/pub
    shm                   2.0G     0  2.0G   0% /dev/shm
    

    and out put as root

    router_a psi # df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda3              14G  5.4G  7.7G  42% /
    udev                   10M  200K  9.9M   2% /dev
    /dev/sda5              14G  2.5G   11G  19% /var
    /dev/sda6              23G   13G  9.3G  58% /home
    /dev/sda7              47G   14G   33G  30% /var/www/localhost/htdocs/pg
    /dev/sda8              51G  201M   51G   1% /mnt/samba
    /dev/sdb1             932G  514G  418G  56% /home/ftp/private/films
    /dev/sdc1             932G  394G  538G  43% /home/ftp/private/files
    /dev/sdd1             112G   89G   24G  80% /home/alex/hdd_120
    /dev/sde1             1.9T  1.3T  538G  72% /home/ftp/private/video
    /dev/sdf1              56G   43G   14G  76% /home/ftp/pub
    shm                   2.0G     0  2.0G   0% /dev/shm
    

    By the way - Thanks to author of PSI for this programm.  I respect pepole writes in pho5 but when i saw that you used XSLT+XML and even wrote your own XSD I gave you + 100 points to my respet to you =)
    Greate work!

    ps - you don't like exceptions?

     
  • jokerper

    jokerper - 2011-01-20

    I hope you still are in here…

    Is it possible to change the command  - mount
    to
    busybox mount

    Somewhere