Only works on Windows at https://localhost

Help
jason404
2012-04-12
2012-12-12
  • jason404

    jason404 - 2012-04-12

    I have been using phpSysInfo on Linux for years, and I have just recently started using it on Windows as well.  But I cannot get it to work.

    IIS 7.5 on Windows Server, using HTTPS.  When I go to https://localhost/phpsysinfo/, it loads fine, but when I replace locahost with the FQDN (on the came local machine and browser), I get no data and the "Error loading XML document!" error.

    The same thing happens when accessing the site using the FQDN remotely as well.  I tried without using HTTPS, but the reulst was the same, so I don't think it has anything to do with that.

    What could cause this XML error when using the FQDN, but when I use localhost it is fine??

     
  • jason404

    jason404 - 2012-04-13

    Okay, I have realised that it started working when I use the option to "Convert to Application".  There seem to be quite a few different options for different app pool types, whatever they are, with different versions of .NET involved.  I'm not sure this relates to PHP.

    However, I cannot get Network Usage stats to show up after converting it to an application in IIS.  How do I get that to work now?

     
  • jason404

    jason404 - 2012-04-13

    I've just noticed that Load Averages is not showing anything either, once converted to an application.  :/

     
  • jason404

    jason404 - 2012-04-13

    SOLVED.

    I got it working with a combination of turning the site into an application and Basic authentication through HTTPS with an admin account controlling the app.

     
  • Anonymous - 2012-11-18

    Got the same error, but can't get it working with the soultion that heled you jason404

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks