#402 com_exception

open-works-for-me
Erkan
None
5
2012-02-25
2010-11-14
Siddus
No

Seems to be a bug in phpsysinfo 2.5.4 on windows 2008 R2 x64... It did run on windows 2003 x64 without problems ??
Uncaught exception 'com_exception' with message 'Source: SWbemServicesEx Description: Not found ' in C:\Program Files (x86)\Apache2.2\htdocs\ftpinfo\includes\os\class.WINNT.inc.php:44
Stack trace: #0 C:\Program Files (x86)\Apache2.2\htdocs\ftpinfo\includes\os\class.WINNT.inc.php(44): variant->Get('Win32_PerfRawDa...')
#1 C:\Program Files (x86)\Apache2.2\htdocs\ftpinfo\includes\os\class.WINNT.inc.php(159): sysinfo->_GetWMI('Win32_PerfRawDa...', Array)
#2 C:\Program Files (x86)\Apache2.2\htdocs\ftpinfo\includes\xml\vitals.php(45): sysinfo->users()
#3 C:\Program Files (x86)\Apache2.2\htdocs\ftpinfo\index.php(183): xml_vitals()
#4 {main} thrown in C:\Program Files (x86)\Apache2.2\htdocs\ftpinfo\includes\os\class.WINNT.inc.php on line 44

Discussion

  • Erkan

    Erkan - 2010-11-15
    • assigned_to: nobody --> jacky672
     
  • Siddus

    Siddus - 2010-11-15

    Problem is that I really like the 2.5.4 version because it is fairly easy to customize.
    I run the aqua (aq) template on it and I have tried the 3.0.5 version but it is impossible to customize it so it runs a simular template (look)..
    Seems that the js-library that you use on the 3.0.x (jquery) doesn't display the data for hardware and memory-usage when there is extra html code right before it ?

     
  • Mieczysław Nalewaj

    • status: open --> open-works-for-me
     
  • Mieczysław Nalewaj

    I met exactly the same problem on some computers.
    It turned out that the problem resulted from errors in WMI. After scanning the system application WMIDiag from page http://www.microsoft.com/download/en/details.aspx?id=7684 in the log there were many errors such as: Root/CIMv2, Win32_PerfRawData_Tcpip_UDP, 0x80041002 - (WBEM_E_NOT_FOUND) Object can not be found.
    The solution I found in the same log:
    You can attempt to resynchronize the WMI performance classes with the existing Windows
    26869 23:33:40 (0) ** performance counters with the following commands:
    26870 23:33:40 (0) ** i.e. 'WINMGMT.EXE /CLEARADAP'
    26871 23:33:40 (0) ** i.e. 'WINMGMT.EXE /RESYNCPERF'

    After running these commands everything back to normal :)

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks