Not Updating Automatically

Bruce
2014-02-21
2014-08-19
  • Bruce

    Bruce - 2014-02-21

    Hi

    I successfully installed PHP Server Monitor on one of my sub-domains.
    All seems to work fine, only thing is that it does not automatically update.
    Every time I have to push the update button. Searched forms high and low, and nothing that works for my site.

    Is it maybe that I inserted 600 "seconds" in the config page? Which the servers then update every 10 minutes??

    Some information:
    PHP server monitor version: 2.1.0
    Server: Cpanel (Linux)
    Site is Htaccess blocked?

    Any suggestions will be great.

    OTHERWISE A GREAT INTERFACE AND A EXCELLENT IDEA FOR ONLINE MONITORING!!!!

     
  • Pep

    Pep - 2014-02-21

    Hi Bruce,

    The refresh interval on the config page is only for automatic refresh of the servers and status page, it does not actually run the updater (hmm perhaps a nice feature..). If you want automatic updates you need to add a cronjob. cPanel supports this, and hopefully your host has not disabled it. Log in to cPanel and under "Advanced" you should find "Cron jobs". Scroll down to "Add New Cron Job", select the desired interval, and enter as command:
    /usr/bin/php /home/your_username/path_to_phpservermon/cron/status.cron.php
    (don't forget to change the username and path).

    That should do the trick!

    Let me know how this works out for you.

    Regards,
    Pep

     
    • Anonymous - 2014-02-21

      Hi Pep

      Thank you so much for your response. Great work by far!!!
      One question, must there be a space after "/usr/bin/php" before it starts again with "/home........".

      Thanks
      Bruce

       
    • Reiner Fuest

      Reiner Fuest - 2014-07-11

      (hmm perhaps a nice feature..)

      For me, I changed your main.tpl.html and replaced the refresh meta tag with a hard coded one and added the URL to update manually. So the server monitor reloads (for me) every 5 minutes and jumps to the update (mod=server_update).

      At this time, the refresh rate is not managable through the GUI. But it must be possible to find the place in your scripts where the meta tag is generated and to add the URL there so the refresh rate is again adjustable through the GUI.

      Greetings,
      Reiner

       
      Last edit: Reiner Fuest 2014-07-11
      • Pep

        Pep - 2014-07-11

        Hi Reiner,

        It would perhaps be a nice feature, however I would really recommend setting up a cronjob for monitoring to avoid any issues with time-outs etc. Feel free to add a feature request to the github page, though, I might add it if I have a spare minute.. Or, a pull request is always welcome.

        Regards,
        Pep

         
  • Anonymous - 2014-02-21

    Hi Pep

    Thanks for your fast response.
    Just a question, must there be a space after "/usr/bin/php" and "/home/........".

    I'm not so great with linux commands.

    Thanks
    Bruce

     
  • Pep

    Pep - 2014-02-21

    Hi Bruce,

    Yes, you do need a space between "/usr/bin/php" (the program to execute, php in this case) and "/home/.../cron/status.cron.php" (the file that php needs to execute).

    Regards,
    Pep

     
  • Bruce

    Bruce - 2014-02-21

    Hi Pep

    Thanks for the support. It worked like a charm.
    If you want some more ideas for your software... email me directly on bruce.geldenhuys@gmail.com

     
  • wondwossen

    wondwossen - 2014-08-19

    Hi pep,

    what about for windows, can you set that things on the windows environment.

     
    Last edit: wondwossen 2014-08-19

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks