phppgadmin - can't call index.php

2008-06-17
2013-06-11
  • last boyscout

    last boyscout - 2008-06-17

    hi,

    I'm a newbie to linux (debian). I have installed apache2, php5, phppgadmin and postgresql. I managed to configure php and apache2 succesfully. In /var/www i have the folder test/index.php with <?php phpinfo(); ?>. When I go to 'localhost' in my browser I can see the 'test'-folder and I get the php-infos when calling the folder. So that works fine!
    Furthermore I have a symbolic link in /var/www --> /usr/share/phppgadmin. So I also see a folder 'phppgadmin' in my webbrowser. But when I click it, my webbrowser always wants to open a '.phtml' file instead of interpreting the index.php (and forwarding to login.php) in the phppgadmin-folder.

    Could anybody please help me?

    Thanks and greetings

     
    • J.Guillaume (ioguix) de Rorthais

      Hello,

      It's pretty hard to help you with anything to check...

      Check your apache2 configuration. You should make sure php can be executed when following symlinks. As instance, copy your /var/www/test/index.php in /var/www/phppgadmin/test.php and try to call it.

      Morevoer, you probably have a phppgadmin conf file in /etc/apache2/site-enabled or something. Check this one as well.

      Try to come on our #phppgadmin IRC chan on irc.freenode.net. If someone is around, you may find some more help.

       
    • last boyscout

      last boyscout - 2008-06-17

      /etc/apache2/sites-enabled was a very good hint! I added the phppgadmin directory there and now it works!

      Thank you very much!!

       
      • J.Guillaume (ioguix) de Rorthais

        To be very complete,

        You meant you did a link from /etc/apache2/site-available/phppgadmin to /etc/apache2/site-enabled/ right ?

        On a side note, it's a bit weird as I thouht this link was done when installing ppa...

         
    • last boyscout

      last boyscout - 2008-06-17

      ähm...no!

      the whole 'sites-enabled' directory has a symbolic link to 'sites-available/default'. this default file  is a configuration for <VirtualHost *> (i didn't really dealt with this topic).
      in this file was the /var/www directory defined (it is the only place where it is defined; i wondered how apache knows this directory because i didn't read this default file before your hint and in apache2.conf '/var/www' it is not mentioned). so I added a <Directory "/usr/share/phppgadmin/">.....</Directory>.

      well and now it works.

      it seems to me as if debian goes its own way with configuring apache...and possible not everything is perfect as I'm using the 'testing'-distribution.

       
      • J.Guillaume (ioguix) de Rorthais

        Reading /usr/share/doc/apache2/* (README.Debian(.gz)? I think) might help you a lot to anderstand how debian mess with conf files.
        There's strong logical idea and best practice behind this.

        Good luck for your next adventures with pg ;)

         

Log in to post a comment.