upgrade upgrade-1.4.2-2.0.0

Help
espiron
2013-04-28
2013-05-14
  • espiron

    espiron - 2013-04-28

    I have a working installation of 1.4.1 and I have followed the instructions for upgrade-1.4.2-2.0.0 (I could not find an upgrade from 1.4.1) but try as I may I keep getting the following error message - Error retrieving config but I have run out of ideas. Can anyone help please?

     
  • Ian Wright

    Ian Wright - 2013-04-29

    At a guess - the message is if the config table can't be found in the database - there are two possible reasons
    You need to copy inc/database.inc to inc/database.inc.php and edit it with the correct connection parameters
    The script admin/upgrade-1.4.2-2.0.0.php creates the config table and takes the contents of inc/config.inc.php and writes them to the table

     
  • espiron

    espiron - 2013-04-29

    I tried that on my non-working updated system and no joy so -

    I deleted everything
    copied the working 1.4.2 system to a new directory
    overwrote the directory contents with the contents of pmfv2-1-0-alpha-1
    ran upgrade-1.4.2-2.0.0.php
    made sure I had copies in inc/ of config.inc.php, database.inc, database.inc.php

    I tried to open in browser and got the message - Error retrieving config

    I must be missing something obvious! I am far from expert at these things but I did get v 1.2.4 working fine although I remember I had difficulties in completing the steps successfuly. I hope you don't run out of patience!

     
  • Ian Wright

    Ian Wright - 2013-04-30

    Did you see any errors when you ran the upgrade script?
    Is there anything listed in error.log? (location depends on setup)
    If you look at the database can you see the config table?
    e.g. DESCRIBE family_config; should show 30 columns for the latest version - 28 for earlier versions (I think)

     
  • espiron

    espiron - 2013-04-30

    I ran the upgrades by putting the address in browser, there was some brief activity and then it siplayed a message in browser saying it could not display the page (or something to that effect). I just tried addressing upgrade-1.4.2-2.0.0.php in my browser just now and got the following message (first time I have seen this)

    CREATE command denied to user 'familyuser'@'localhost' for table 'family_config'phpmyfamily: Error creating config table!!!

    I looked up the config file for mysql and it said that "error.log now goes to syslog (a Debian improvement)" I looked in there and there was nothing I could identify with mysql errors.

    There are only the following tables listed
    | Tables_in_family |
    +---------------------+
    | family_census |
    | family_census_years |
    | family_documents |
    | family_images |
    | family_people |
    | family_spouses |
    | family_tracking |
    | family_users |

    I hope this helps.

     
  • Ian Wright

    Ian Wright - 2013-05-01

    I did mean the Apache error.log (could be in /var/log/apache2) but this message helps anyway.

    You will need to give the MySQL user familyuser@localhost permission to create and alter tables for the upgrade to work - for a database family the easiest way to do this is (as root):
    GRANT ALL ON family.* TO familyuser@localhost;

     
  • espiron

    espiron - 2013-05-01

    WOW!!!! It all worked like a dream - thank you so much, you must have endless patience to deal with people like me. I am absolutely delighted - thank you for a brilliant programme.

     
  • espiron

    espiron - 2013-05-03

    I have tried to amend the description below an image and I get the following message
    Message could not be sent.
    Mailer Error: Language string failed to load: Authentication failed

     
  • espiron

    espiron - 2013-05-04

    I now realise that the edits are recorded ok, I believe the message may refer to email notification but I cannot see why that is now a problem, the mail addresses are the same as with the earlier version. I have tried changing config.inc.php -
    Put $mailto = false - no change
    Put $bbtracking = false - no change

     
  • Ian Wright

    Ian Wright - 2013-05-07

    That sounds plausible
    config.inc.php is no longer used in version 2 - use /admin.php instead

    The mail configuration has changed (as of 2.0.4) and is now part of /admin.php where you will need to fill in the details

     
  • espiron

    espiron - 2013-05-07

    I have looked at /admin.php but I can not see anything which seems relevant I could change there.

     
  • Ian Wright

    Ian Wright - 2013-05-09

    You need to set the smtp options for your mail server - the php mail function is no longer used as it is not always supported therefore you now need to configure outgoing mail
    i.e. smtp_host, smtp_user and smtp_password
    The contact form also uses this

     
  • espiron

    espiron - 2013-05-10

    I am using sendmail and it is already configured to send mail , using a perl script - form2email.pl, which it does from forms in other sites on my server. All i needed to do with form2email.pl was to identify the name & location of sendmail. Would this not be the same for phpmyfamily? I apologise if I am missing something.

     
  • Ian Wright

    Ian Wright - 2013-05-12

    Try localhost (or your server name) as the smtp_host
    Depending on your sendmail configuration you may (should!) need to put in user details

     
  • espiron

    espiron - 2013-05-12

    Thank you - where do I enter the host name (localhost)?

     
  • espiron

    espiron - 2013-05-12

    I have already tried changing
    $mail->Host = $config->smtp_host; to $mail->Host = $config->localhost;
    in mail.php.
    Sendmail is configured to allow users from localhost to send mail.

     
  • Ian Wright

    Ian Wright - 2013-05-13

    That won't help...
    You enter the host name on the /admin.php page under smtp_host (which changes the entry in the config table in the database)

    (If you really want to change the php then it would be
    $mail->Host = 'localhost';)

     
  • espiron

    espiron - 2013-05-13

    Sorry but there is no smtp_host on the /admin.php page and I previously did change mail.php where it says $mail->Host = 'smtp_host' to $mail->Host = 'localhost' but as I said, that did not cure the problem.

     
  • Ian Wright

    Ian Wright - 2013-05-14

    It's towards the bottom of the page on the left hand side in the last row of the options table and is in v2-0-4 and later.

    You'll have to try checking your apache error.log and sendmail logs to see what is going on

     
  • espiron

    espiron - 2013-05-14

    Is that before or after the GEDCOM table? I am using version 2.1.0-alpha-1.
    I have combed through all the logs (mail, auth, apache etc) but can not see anything which appears related. I did a text search in admin.php for 'smtp_host' but it found nothing.

     
  • Ian Wright

    Ian Wright - 2013-05-14

    before Upload Gedcom File

    4th row of the table under gmapskey

    it's in modules/admin/editForm.php

     
  • espiron

    espiron - 2013-05-14

    I am having no luck here. I have edited modules/admin/editForm.php, I added 127.0.0.1
    on line 76 and also a linux user and password in lines 77 & 78. I added a new person 'test' and was able to edit this and called him 'mr' I then tried to delete the new person and I again get

    Message could not be sent.
    Mailer Error: Language string failed to load: Authentication failed

    I can add any number of new persons but I cannot edit or delete them

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks