#90 Cant change admin options

1.94
open
nobody
None
1
2014-01-30
2013-12-07
Anonymous
No

When I try to change admin options I get an error. I am using version - 1.94-RC2 -

Not Acceptable

An appropriate representation of the requested resource /chat/admin.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


Everything else works fine. can register new members and all else is fine. I just cant set up the admin options.

Thank you,

Worthless1@worthlessopinion.com

Discussion

  • Ciprian Murariu

    Ciprian Murariu - 2013-12-08

    Please try the site admin section/error log and are if there is a more specific explanation. It could be the sessions disabled on newer php versions, but not sure.
    We need more info to hunt down this behaviour.
    Can you provide a link?
    Can you separately install rc4 or even upgrade your chat to latest?
    Ciprian M.

     
    Last edit: Ciprian Murariu 2013-12-08
  • Anonymous - 2013-12-09

    http://worthlessopinion.com/chat/

    I can not see any entry for an error log.

    I do not know if I could manually upgrade to a newer version, I am not very good at website building, and this is my first chat ever.

    Thank you very much for your time, and let me know if there is anything else I an do for you.

     
  • Anonymous - 2013-12-09

    I should have been more clear?

    I get the error when I try to change "configuration" under admin area.

    I can change any value, but when I try to hit "save" I get the error that says
    "
    Not Acceptable

    An appropriate representation of the requested resource /chat/admin.php could not be found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    When I look in the directory, I do see the file chat/admin.php

    Thank you again.

     
  • Anonymous - 2013-12-09

    Why don't my newest answers show here?

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-09

    Because you were posting as anonymous, so they were awaiting for moderation.

     
  • Anonymous - 2013-12-12

    Is that it? No more answers or are you busy?

    Please let me know.

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-12

    Yes, sorry, busy like hell with a new job, moved with family to a new country, my laptop is broken, so it will take a while to get back on track.
    But be sure I'll get on and let you know.
    Thanks.

    Wonderful Holidays meantime ;)
    Ciprian M.

     
    Last edit: Ciprian Murariu 2013-12-13
  • Anonymous - 2013-12-12

    Same problem here even with RC3. Tried multiple machines and internet programs (IE and FF). Says admin.php can not be found however I have it in RC2 and RC3 right were it should be but no dice.

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-12

    Try RC4 and see what you get.
    Latest php>5.3 versions might have security mods enabled that causes that. Anyway, prior versions were not compatible with php 5.3 and above.

    LE: sorry, RC3 is the latest released. I was confused! Huhh

     
    Last edit: Ciprian Murariu 2013-12-13
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-12

    Make sure you DON'T use single quotes in any field in the config area. That should be fixed in RC3 only.

     
    Last edit: Ciprian Murariu 2013-12-13
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-12

    First poster, read your chat lurking. I made some suggestions and comments.
    Second poster, you can also look there and see if any applies.
    That will only be visible for the next 4 days.

    I don't understand why you post anonymously, how do you get notified then? I think I will restrict posting to reg users here, so I don't waste my time.

    All the best!

     
  • Anonymous - 2013-12-13

    Ciprian , Hope you and the Family have a great holiday, and thank your for your time. I'll let you know if a new version helps the problem.

     
    • Ciprian Murariu

      Ciprian Murariu - 2013-12-13

      Thank you! All the best to you too!

       
  • Anonymous - 2013-12-13

    Where is a link for RC4?

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-13

    This is from the FAQ:

    10Q.
    I cannot make any changes in the admin panel. It says it was successfully updated, but when I check back, nothing changed.
    10A.
    a. A reason could be if you use the ' character in a field, without commenting it out with a backslash .
    Example:
    If a room name is called Men's Room, you have to comment it out with \' like this: Men\'s Room.
    But I strongly recommend you avoid ussage of the ' (use ’ instead) or \ chars in your chat setting values.
    b. There is something wrong in your database (c_config table) like the order of the fields or types/sizes of them.
    c. You’re using a wrong config/config.lib.php file or admin/admin5.php one - if you upgraded (make sure you replaced the old one with the new released one).

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-13

    First poster, please make me admin in http://worthlessopinion.com/chat/ so I can check myself. Let me know.

     
  • Anonymous - 2013-12-14

    No single quotes anywhere. Checked all permission settings per manual install instructions. Nothing works. RC3

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-15

    I'm not sure which one of you is posting. 2 anonymous with two different setups. How can I help...

     
  • Anonymous - 2013-12-15

    Sorry to be doing this as anon.

    I didn't know it mattered, but I have signed up and will use my user name from now on.

    My apologies.

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-16

    It's ok. Usually it doesn't matter, but in this case, you were two in the same topic ... you can imagine I wouldn't know who's posting when... ;-)

     
  • Ciprian Murariu

    Ciprian Murariu - 2013-12-16

    One question: during the setup, did you change the table names? they should be like c_config not config. rename them back to leading c_ prefix, except for bot ones. If you install (or reinstall) RC3, keep the default table names.

     
  • Worthless1

    Worthless1 - 2013-12-18

    I have not changed any code anywhere. everything is as installed, and I used the auto install. I believe the problem could be because I am not running your newest version, with my php 5.4.23.

    I will install your newest version and let you know what happens.

    I will not be able to do it right away, so it will probably be after the holidays before I get to it.

    Meanwhile, I hope you have a good Holiday, and thank you for all the help.

    And, I am no longer anonymous !

    Peace.

     
  • Anonymous - 2014-01-01

    Still can't save admin settings. Tried Cpanel auto install. Tried manual install. Get same message. Tried IE and FF. No luck.

     
    • Ciprian Murariu

      Ciprian Murariu - 2014-01-01

      Happy New Year!
      You're Worthless1? Did you install 1.93-RC3, keeping the provided/default table name format?

       
      • Worthless1

        Worthless1 - 2014-01-20

        Hello,

        I am sorry for the delay in getting back to you.

        Yes, This is Worthless1@worthlessopinion.com

        The version I am using is 1.94 RC2

        I have not changed anything, the files are exactly as I downloaded and
        installed them.

        Thank you, and I hope you have a Happy and prosperous New Year.

        Happy New Year!
        You're Worthless1? Did you install 1.93-RC3, keeping the provided/default
        table name format?


        [bugs:#90] Cant change admin options

        Status: open
        Created: Sat Dec 07, 2013 08:26 PM UTC by Anonymous
        Last Updated: Wed Jan 01, 2014 08:44 PM UTC
        Owner: nobody

        When I try to change admin options I get an error. I am using version -
        1.94-RC2 -


        Not Acceptable

        An appropriate representation of the requested resource /chat/admin.php
        could not be found on this server.

        Additionally, a 404 Not Found error was encountered while trying to use an
        ErrorDocument to handle the request.


        Everything else works fine. can register new members and all else is fine.
        I just cant set up the admin options.

        Thank you,

        Worthless1@worthlessopinion.com


        Sent from sourceforge.net because you indicated interest in
        https://sourceforge.net/p/phpmychat/bugs/90/

        To unsubscribe from further messages, please visit
        https://sourceforge.net/auth/subscriptions/

         
  • Ernest Alzate

    Ernest Alzate - 2014-01-30

    any luck with this?
    im actually having the same issue. I also auto installed in cpanel. it installed 1.94 RC2

    im actually upgrading to rc3 now.

     
  • Ernest Alzate

    Ernest Alzate - 2014-01-30

    ok so after updating it to rc3 i am getting this error when i click on "configurations"

    Database error: Invalid SQL: SELECT id FROM bot_bots WHERE id!='0'
    MySQL error: 1146 (Table 'chat.bot_bots' doesn't exist)
    Session halted.

     
  • Ernest Alzate

    Ernest Alzate - 2014-01-30

    disregard my last message... im back to rc2. for now.. just want to figure out that error... email me: ernest.alzate@gmail.com . I made a username for you so you can see what its doing( configuration not going through error)

    Thank you

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks