empty backup files

Help
2007-07-06
2013-05-30
  • Nobody/Anonymous

    Everything seems to work, but the backup file created is always 0 bytes.. i.e. an empty file

    PHP Version 5.2.1
    MySQL 4.1.22-standard
    phpMBP v.2.1

     
    • Xavier de Pedro

      Xavier de Pedro - 2007-08-08

      Same for me, using
      PHP Version 4.3.11
      MySQL 4.0.24-standard
      phpMBP v.2.1

       
      • Nobody/Anonymous

        You all should give more informations!
        PHP configuration, OS, DB size, compression mode, etc.
        Important: Is SAFE MODE ON or OFF ???
        Try to turn safe mode ON. Does it work now?

         
    • Nobody/Anonymous

      Yes, had the same problem - went back to version 1.8 and everything was fine!

      Noel

       
    • Nobody/Anonymous

      same problem over here

       
    • Nobody/Anonymous

      same problem...

       
    • Nobody/Anonymous

      You all should give more informations!
      PHP configuration, OS, DB size, compression mode, etc.
      Important: Is SAFE MODE ON or OFF ???
      Try to turn safe mode ON. Does it work now?

       
    • Nobody/Anonymous

      I am also get the problem with zero size files.

      I have tryed both 1.8 and 2.1 same result.. Both on email and ftp backup the files are empty

      I am running LAMP

      MySQL 4.1.21
      PHP 4.4.7 - with safe mode on

      / Jacob

       
    • Nobody/Anonymous

      I fixed it.
      I have used hostgator.com server, my MySQL database has around 20Mb.

      What I did?
      1. Make php.ini file with two line:
      memory_limit = 100M
      safe mode = on
      2. Upload this file in to phpMyBackupPro directory

      Enjoy! Working for me well.

      Maverick

       
    • Nobody/Anonymous

      THX FOR THIS!!

      php.ini

      content:
      memory_limit = 100M
      safe mode = on

      READY and Upload to phpMyBackupPro directory

      100% OK!

       
      • Nobody/Anonymous

        Same problem here ... 1.8 works fine ... 2.1 creates zero-byte files. Safe mode is OFF.

         
    • porzeraczmuzguw

      porzeraczmuzguw - 2008-10-15

      So it looks that there is an error in 2.1

       
  • Phil Newby

    Phil Newby - 2009-09-20

    Hi Same issue for me.

    My automated backups from v2.1 were working fine, till last week when the database hit 17MB then all bakups were 0KB.

    the php.ini didn't work for me but version 1.8 works fine.

    My details…
    Server
    Zeus/4.3
    PHP
    PHP Version: 4.4.9 Safe Mode activated: no PHP Memory Limit: *Can not be retrieved*
    gzip compression possible: yes Emails sendable: yes FTP transfer possible: yes
    MySQL Server: 5.0.58-enterprise-gpl MySQL Client: 4.1.22

    phil

    <a hfref='http://www.haroldstreet.org.uk/'>www.haroldstreet.org.uk</a>

     
  • barespirit

    barespirit - 2010-01-18

    My server has about 15 databases of different sizes.  I installed version 2.1, and have not tried 1.8.  My php.ini was already set to 100m, safemode is off.  PHP is 4.3, RedHat.

    Databases up to about 15 mb copied ok, there was a 30 mb db that made a zero byte file, and I got a white page lockup when it tried either a 70 mb or 250 mb db.

    By changing the memory and timeout settings, I got the 30 mb db to backup, but making the settings even higher did not help with the 70 and 250 mb dbs.  I tried changing php.ini to allow 2000 mb uploads with no change.  Something is not right here, and I welcome any new suggestions.  How can I get 1.8?

     
  • martin dorren

    martin dorren - 2010-07-09

    empty backups here too.  I created the php.ini file and the program doesn't change to safe mode.

     
  • TheDoctore

    TheDoctore - 2010-12-13

    I had the same issue and tried debugging the code for hours before I found this thread. To fix the issue, I created a php.ini file with the line "memory_limit = 256M;" (I have a dedicated server with plenty of mem so I put it high to avoid future issues.) and saved it into the backup folder where i run my backup file. I use the same working folder as PhpMyBackupPro v 2.1.

    The last working backup that was send was 32mb when i had the line set to 64mb. Currently its at 42mb and still works.

    Note: If this solution doesnt work for you you, make sure your server supports putting php.ini files in directories.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks