#914 (in 2.5.2) Incorrect record count for subqueries (MySQL 4.1)

2.5.1
fixed
1
2013-06-11
2003-06-28
Anonymous
No

When submitting a query (with in my case a subquery)
the results shows a wrong count (Showing rows 0 - 0 (1
total, Query took 0.0003 sec)) and it is not possible
to browse the result set (no back and forward arrows).
When I execute the same query in a mysql window
(command line), the result is correct.

Version 2.5.1; Also present in version 2.5.2-dev (just
downloaded and tested)
MySQL version 4.1 alpha

PS. Keep up the good work! phpMyAdmin is wonderful and
very useful!

Discussion

  • Alexander M. Turek

    Logged In: YES
    user_id=418833

    Could you give me an example query that fails? Or does every
    subquery fail? Does it work correctly with "normal" queries?

     
  • Alexander M. Turek

    • summary: Incorrect record count (0-0), no browsing possible of result --> (2.5.1) Incorrect record count for subqueries (MySQL 4.1)
     
  • Nobody/Anonymous

    Logged In: NO

    I encounter it only with the MySQL 4.1a db when using
    subselects. Other queries work perfect.

    This is the query that I used:
    SELECT * FROM `fragment`
    WHERE f_comment = "Trypsine_P" AND f_seq NOT
    IN (
    SELECT f_seq
    FROM fragment
    WHERE f_comment = "Trypsine"
    GROUP BY f_seq );

     
  • Nobody/Anonymous

    Logged In: NO

    I encounter it only with the MySQL 4.1a db when using
    subselects. Other queries work perfect.

    This is the query that I used:
    SELECT * FROM `fragment`
    WHERE f_comment = "Trypsine_P" AND f_seq NOT
    IN (
    SELECT f_seq
    FROM fragment
    WHERE f_comment = "Trypsine"
    GROUP BY f_seq );

     
  • Luc Krols

    Luc Krols - 2003-06-30

    Logged In: YES
    user_id=812446

    Follow up: (I logged in this time). When executing the same
    query in a mysql client window or via ODBC, it works
    perfect. Only when executing the query from within the
    phpMyAdmin web interface (2.5.2-dev, 2.5.1) that the error
    occurs.

     
  • Alexander M. Turek

    • assigned_to: rabus --> lem9
     
  • Marc Delisle

    Marc Delisle - 2003-07-08
    • status: open --> open-fixed
     
  • Marc Delisle

    Marc Delisle - 2003-07-08
    • priority: 5 --> 1
    • summary: (2.5.1) Incorrect record count for subqueries (MySQL 4.1) --> (in 2.5.2) Incorrect record count for subqueries (MySQL 4.1)
     
  • Marc Delisle

    Marc Delisle - 2003-07-08

    Logged In: YES
    user_id=210714

    Please confirm the fix, using the latest cvs snapshot.

     
  • Luc Krols

    Luc Krols - 2003-07-08

    Logged In: YES
    user_id=812446

    Perfect!! It works! I tested the 2.5.2-dev (latest CSV release
    downloaded today and it works perfectly. I used the same
    query as mentioned below on the same database. I tested
    both under Netscape 7.02 and IE 6.0.

    Thanks for fixing it! Keep up the good work!

    c.u.

    Luc

     
  • Marc Delisle

    Marc Delisle - 2003-07-22
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks