#913 (in 2.5.2) timestamp export fails (MySQL 4.1)

2.5.1
fixed
1
2013-06-11
2003-06-27
No

if you export a timestamp from mysql 4.1 it gets the
normal datetime format, but is exported without quotes,
thus you cant import it ...

I fixed lines 285/286 and 464/465 removed the
timestamp entry witch works in my environment.
from
if ($type == 'tinyint' || $type == 'smallint' || $type
== 'mediumint' || $type == 'int' ||
$type == 'bigint' || $type=='timestamp' ) {
to
if ($type == 'tinyint' || $type == 'smallint' || $type
== 'mediumint' || $type == 'int' ||
$type == 'bigint' ) {

greetings

Discussion

  • Alexander M. Turek

    Logged In: YES
    user_id=418833

    Yes, your fix works in your environment, but it'll break the
    code for MySQL 4.0 users ;-)

    Thanks for your report, I'll work on this issue.

     
  • Alexander M. Turek

    • summary: timestamp export failes caused by new format --> (2.5.1) timestamp export failes caused by new format
     
  • Alexander M. Turek

    • summary: (2.5.1) timestamp export failes caused by new format --> (2.5.1) timestamp export fails (MySQL 4.1)
     
  • Alexander M. Turek

    Logged In: YES
    user_id=418833

    fixed in CVS.

     
  • Alexander M. Turek

    • priority: 5 --> 1
    • summary: (2.5.1) timestamp export fails (MySQL 4.1) --> (in 2.5.2) timestamp export fails (MySQL 4.1)
    • status: open --> open-fixed
     
  • Marc Delisle

    Marc Delisle - 2003-07-22
    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks