#871 (in 2.5.1) Blank screen

Latest_Git
fixed
None
1
2013-06-11
2003-05-21
Anonymous
No

when opening phpmyadmin 2.5.1 cvs,
I only see a blank screen.

I' am operating on Linux with MySql 4.1.0

This Error hasn't occured with the previous Versions
(testet with 2.5.0, 2.4.0 and 2.3.3)

Discussion

  • Garvin Hicking

    Garvin Hicking - 2003-05-21

    Logged In: YES
    user_id=473563

    What browser are you using? If you try to view the source of
    that "blank screen", do you get any output?

    Apart from that, phpMyAdmin does not currently support MYSQL
    4.1.0 and can't be used with that version.

     
  • Nobody/Anonymous

    Logged In: NO

    Hi, I get exactly the same error!

    For reference, please see BUG #738508

    (The Bug is initially the MaxExactCount,
    but could not be resolved further, because I
    too get the BLANK SCREEN).

     
  • Nobody/Anonymous

    Logged In: NO

    Hi,

    even the new CVS from:

    21-May-2003 06:06

    (.php version in .tar.gz)

    Gives blank screen.

     
  • Michal Čihař

    Michal Čihař - 2003-05-22

    Logged In: YES
    user_id=192186

    Hi

    Just played with our online demo and the problem is in

    $testGD = @imagecreatetruecolor(12,12);
    (libraries/defines_php.lib.php3)

    It produces fatal error:
    Fatal error: imagecreatetruecolor(): requires GD 2.0 or later in
    /home/groups/p/ph/phpmyadmin/htdocs/phpMyAdmin/libraries/defines_php.lib.php3
    on line 67
    which causes php to terminate and send blank screen....

     
  • Michal Čihař

    Michal Čihař - 2003-05-22
    • status: open --> open-accepted
     
  • Nobody/Anonymous

    Logged In: NO

    Browser doesn't matter I think.
    both, Mozilla 1.3.0 and IE 6.0 shows a blank site.

    The HTML source code of the Blank site :

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0
    Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html;
    charset=iso-8859-1"></HEAD>
    <BODY></BODY></HTML>

    I think that it doesn't matter if using mysql 4.0 or 4.1 because
    only the charsets in mysql 4.1 aren't supportet and with
    phpmyadmin 2.4.0 and 2.5.0, there are no blank sites with
    mysql4.1.0.

     
  • Pia Andersson

    Pia Andersson - 2003-05-22

    Logged In: YES
    user_id=784457

    Hi

    I have a rh7 linux / cpanel server with mysql 4.0.12 and I'm
    getting the blank page at phpMyAdmin/index.php. It was
    working fine and then wasn't... so obviously the automatic
    updates changed something and the blank page showed up.

    I use IE6 to view it with. The page source of the blank screen
    is:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0
    Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html;
    charset=windows-1252"></HEAD>
    <BODY></BODY></HTML>

    When viewed with Mozilla 1.2.1 it also returns a blank page;
    the page source is also blank.

    Very keen to work out why this has happened as we have
    been unable to find a cause and neither has anyone else and
    its a live production server :o(

    Thanks!

     
  • Garvin Hicking

    Garvin Hicking - 2003-05-22

    Logged In: YES
    user_id=473563

    For a quick fix, edit your libraries/defines_php.lib.php3
    and replace the line

    $testGD = @imagecreatetruecolor(12,12);

    with

    $testGD = false;

    Or, if you are certain that you have the GD2 graphics
    library enabled, you can set $testGD to true.

    It's hard to find a good GD2 detection routine with PHP <
    4.3.0, so our developers are currently thinking about a
    solution for those users.

    Regards,
    Garvin.

     
  • Nobody/Anonymous

    Logged In: NO

    Aah!

    Then I know why I get a blank screen!

    My GD-Lib is added dynamically at
    runtime by

    function load_graphic_extension()
    {
    if (!extension_loaded('gd'))
    {
    if (!dl('gd.so'))
    {
    print "Cannot load Library!";
    exit;
    }
    }
    }

    Maybe you can include this scenario into your
    sourcecode, too.

     
  • Michal Čihař

    Michal Čihař - 2003-05-22
    • assigned_to: nobody --> nijel
     
  • Michal Čihař

    Michal Čihař - 2003-05-22

    Logged In: YES
    user_id=192186

    I will fix this, the loading is not the only problem...

    Michal

     
  • Pia Andersson

    Pia Andersson - 2003-05-22

    Logged In: YES
    user_id=784457

    I can't find this in my install of 2.5.0
    $testGD = @imagecreatetruecolor(12,12);

    In the file defines_php.lib.php I have

    // Whether GD2 is present
    if (!defined('PMA_IS_GD2')) {
    if (function_exists("get_extension_funcs")) {
    $testGD = @get_extension_funcs("gd");
    if ($testGD && in_array("imagegd2",$testGD)) {
    define('PMA_IS_GD2', 1);
    } else {
    define('PMA_IS_GD2', 0);
    }
    unset($testGD);
    } else {
    define('PMA_IS_GD2', 0);
    }
    }

    I am still working on it. My cpanel server is running GD 1.8....
    Is it essential to use gd 2 ?

     
  • Michal Čihař

    Michal Čihař - 2003-05-22

    Logged In: YES
    user_id=192186

    Yes we need GD2 because it is used for work with truecolor
    pictures and ong GD >= 2 supports this...

     
  • Michal Čihař

    Michal Čihař - 2003-05-22
    • priority: 5 --> 1
    • summary: Blank screen --> (in 2.5.1) Blank screen
    • status: open-accepted --> open-fixed
     
  • Michal Čihař

    Michal Čihař - 2003-05-22

    Logged In: YES
    user_id=192186

    Should be fixed in CVS.

     
  • Nobody/Anonymous

    Logged In: NO

    It works fine now, thanks

     
  • Alexander M. Turek

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks