#867 (in 2.5.1) Validate SQL

2.5.0
fixed
1
2013-06-11
2003-05-17
deepz0ne
No

Fatal error: Cannot pass parameter 2 by reference
in /usr/local/apache/htdocs/db/libraries/sqlvalidator.class.
php on line 108

Discussion

  • Garvin Hicking

    Garvin Hicking - 2003-05-24

    Logged In: YES
    user_id=473563

    Which php version?

     
  • deepz0ne

    deepz0ne - 2003-05-24

    Logged In: YES
    user_id=330295

    4.3.1 and 4.3.2 all RCs - PHP running as apache module, 1.3.27

     
  • Garvin Hicking

    Garvin Hicking - 2003-05-28

    Logged In: YES
    user_id=473563

    Thank you for reporting, this bug was caused by a new
    PHP/PEAR variable propagation mechanism incompatible to our
    script.

    I fixed the bug in CVS.

    Regards,
    Garvin.

     
  • Garvin Hicking

    Garvin Hicking - 2003-05-28
    • priority: 5 --> 1
    • assigned_to: nobody --> garvinhicking
    • summary: Validate SQL --> (in 2.5.1) Validate SQL
    • status: open --> open-fixed
     
  • deepz0ne

    deepz0ne - 2003-05-29

    Logged In: YES
    user_id=330295

    Hey, that's really nice feature!

    It worked here with latest snapshot (2.5.1-rc2) , php 4.3.2
    and PEAR 1.1 !

    Hoever i can't understand why error links in validated sql
    result are to something like #errpos1369133069.1 (if i click
    on them , opens phpmyadmin inside right frame again.) Is
    this bug or i have to configure some docroots for manuals or
    something else?

     
  • deepz0ne

    deepz0ne - 2003-05-29

    error in errorlinks?

     
    Attachments
  • Alexander M. Turek

    • status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks