#4413 (ok 4.2.8) Navigation Error in Nav Tree for Search Results Past the First Page

4.2.7
fixed
1
2014-08-31
2014-05-14
Owen
No

Observed Behavior

Default tables shown on one page is 25. After filtering the tables, when expanding a table that would normally be past the first page, a "An error has occurred while loading the navigation tree" error is shown.

Expected Behavior

Tables can be expanded at any time

Steps to Reproduce

  1. Create some tables using the attached SQL script
  2. Expand the list of tables in the database
  3. Filter the tables by '3'
  4. Expand table38

Discussion

  • Madhura Jayaratne

    I have difficulty in reproducing this bug.
    If I set 'Maximum items in branch' to 25, table38 would be on the second page and filtering for 3 would not bring it to view.
    If I go with default value for 'Maximum items in branch', 50 and filter for 3, it would achieve the filtered list shown in the attachment. However I'm still not getting the error you see when expanding table 38.

     
  • Owen

    Owen - 2014-06-09

    I'm attaching a screencast of reproducing the error. Apologies for the Flash format but, it's the only screencast software available to me.

     
  • Madhura Jayaratne

    Thanks Owen. I can reproduce the bug following the steps in your screencast.

     
  • Marc Delisle

    Marc Delisle - 2014-06-20

    Madhura, can you also reproduce it with version 4.2.3?

     
  • Madhura Jayaratne

    Marc, it seems to be fixed in QA_4_2 branch.

     
  • Marc Delisle

    Marc Delisle - 2014-06-20

    Thanks Madhura for the feedback.

     
  • Marc Delisle

    Marc Delisle - 2014-06-20
    • summary: Navigation Error in Nav Tree for Search Results Past the First Page --> (ok 4.2.4) Navigation Error in Nav Tree for Search Results Past the First Page
    • status: open --> fixed
    • assigned_to: Madhura Jayaratne
     
  • Madhura Jayaratne

    • summary: (ok 4.2.4) Navigation Error in Nav Tree for Search Results Past the First Page --> Navigation Error in Nav Tree for Search Results Past the First Page
    • status: fixed --> open
    • assigned_to: Madhura Jayaratne --> nobody
     
  • Madhura Jayaratne

    Hi Marc,

    My mistake, I misread the bug report. The bug is still there.

     
  • Marc Delisle

    Marc Delisle - 2014-06-20
    • Group: 4.2.1 --> 4.2.3
     
  • Marc Delisle

    Marc Delisle - 2014-06-20
    • Group: 4.2.3 --> 4.2.4
     
  • Atul Pratap Singh

    • assigned_to: Atul Pratap Singh
     
  • Atul Pratap Singh

    • summary: Navigation Error in Nav Tree for Search Results Past the First Page --> (ok 4.2.8) Navigation Error in Nav Tree for Search Results Past the First Page
    • status: open --> resolved
    • Group: 4.2.4 --> 4.2.7
    • Priority: 5 --> 1
     
  • Marc Delisle

    Marc Delisle - 2014-08-31
    • Status: resolved --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks