#4346 (ok 4.1.13) Incorrect "Export incomplete" message

4.1.12
fixed
None
1
2014-10-11
2014-03-31
azurIt
No

Suddenly, exporting started to display this error IMMEDIATELY after clicking on 'Go' button:
"Your export is incomplete, due to a low execution time limit at the PHP level"

The exported file is NOT incomplete. Even more, after this happens, every other action in the GUI results into this error:

"Error: Token mismatch"

Full page reload or relogin fixes the token problem.

Discussion

  • Marc Delisle

    Marc Delisle - 2014-04-05

    What is your PHP execution time limit?

     
  • Marc Delisle

    Marc Delisle - 2014-04-05
    • status: open --> pending
     
  • azurIt

    azurIt - 2014-04-05
    <Directory /usr/share/phpmyadmin/>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/usr/share/phpmyadmin/:/tmp/:/usr/share/php/:/proc/stat:/proc/meminfo:/var/tmp/"
    php_admin_value max_execution_time 1200
    php_admin_value max_input_time 1200
    php_admin_value memory_limit 400M
    php_admin_value post_max_size 400M
    php_admin_value upload_max_filesize 200M
    </IfModule>
    </Directory>
    
     
  • Marc Delisle

    Marc Delisle - 2014-04-06
    • status: pending --> open
     
  • azurIt

    azurIt - 2014-04-09

    Attaching log from LiveHTTPHeaders from FF (hope i censored everything sensitive).

    There is nothing in the JS console.

    What else do you need? This is always reproduceble but not on all of our servers (we are using one PMA installation for several servers).

     
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Hey, I need the response of the GET request "https://censored/export.php?ajax_request=true&token=censored&check_time_out=true&_nocache=1397047124605884945".
    and LiveHTTPHeaders doesn't show responses, so it would be nice if you can install Firebug, then do right click on export page -> Inspect element with firebug -> open console tab -> now do export by clicking "Go" button on the page -> in console you will see above export.php url -> expand that -> click on response to check the response. Please copy paste the response here :-).
    Can you also let me know, on what kind of server(os, server name ) this bug is occurring as you said it is not happening on all your servers.

     
    Last edit: Smita Kumari 2014-04-09
  • azurIt

    azurIt - 2014-04-09

    Here is the response:

    {"success":false,"error":"<div class=\"error\"><img src=\"themes\/dot.gif\" title=\"\" alt=\"\" class=\"icon ic_s_error\" \/> Your session has expired. Please log in again.<br \/><br \/>[ <a href=\"https:\/\/<censored>\/\" class=\"ajax login-link\">Log in<\/a> ]<\/div>"}
    

    As always, DB was exported correctly and downloaded dump was complete.

    It is occuring on Debian Wheezy (host system) which is connecting to other Wheezy and Squeeze systems (both are affected), MariaDB 5.5.35. I found only two servers where it's working, both were Squeeze.

    One more thing - the host system is using memcached to store PHP sessions (but i still don't understand why the problem is NOT appearing on few servers):
    session.save_handler = memcache
    session.save_path = "tcp://127.0.0.1:11211?persistent=0&weight=1&timeout=1&retry_interval=-1"

     
    Last edit: azurIt 2014-04-09
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Hey, Sorry for so many questions. but it seems your session is expiring. After logging in, are you able to do other stuff like running sql queries on some DB or creating table from within PMA on these servers ? Also as per http://www.php.net/manual/en/memcached.sessions.php
    If I'm right Session configurations for memcached should be like
    session.save_handler = memcached

     
    Last edit: Smita Kumari 2014-04-09
  • azurIt

    azurIt - 2014-04-09

    The sessions are fully working, PMA is not the only PHP application which runs on that server (see the first comment on page you linked). PMA is fully working, i can list databases, tables, run queries etc. And, again, exporting is fully working too except that error message and 'Token mismatch' problem after exporing is done (which can be fixed by just CTRL + F5, see the original report above). I can create you a test account if you want but login information must be sent privately only to you.

     
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Thanks a lot! :-) If I need an account, I'll ask for it. Thank you!

     
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Hi, It would be nice if you can send me a test account info on the email kumarismita62@gmail.com . I'll let you know when I'm done so that you can delete the same. Thank you :-).

     
  • azurIt

    azurIt - 2014-04-09

    done

     
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Hi, You can delete that test account. I got my mistake, 'll submit a patch soon.
    Thanks a lot for all your help :-)

     
  • azurIt

    azurIt - 2014-04-09

    cool, thank you :)

     
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Hi Marc, I have submitted a pull request for this bug https://github.com/phpmyadmin/phpmyadmin/pull/1131/files . As I was not able to reproduce it on my machine so couldn't test but I hope this patch will fix this issue.
    Thanks.

     
  • azurIt

    azurIt - 2014-04-09

    looks fixed, thanks

     
  • Smita Kumari

    Smita Kumari - 2014-04-09

    Thanks you! :-)

     
  • Marc Delisle

    Marc Delisle - 2014-04-10
    • summary: Strange export problem --> Incorrect "Export incomplete" message
    • assigned_to: Marc Delisle
     
  • Marc Delisle

    Marc Delisle - 2014-04-10
    • summary: Incorrect "Export incomplete" message --> (ok 4.1.13) Incorrect "Export incomplete" message
    • status: open --> resolved
    • Priority: 7 --> 1
     
  • Marc Delisle

    Marc Delisle - 2014-04-13
    • Status: resolved --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks