#4313 (ok 4.2.1) GIS Visualization Extension does not work with PointFromText() function

3.5.8
fixed
gis (1)
1
2014-10-24
2014-03-06
kureta
No

I have changed my table structure to use proper GIS extensions due to this bug. So, I am not able to export my db structure.

The problem is that I had 2 DECIMAL columns (geo_lat, geo_long) and I was trying to visualize my data using GIS, with the following query:

SELECT name, PointFromText( Concat( 'POINT (', geo_lat, ' ', geo_long, ')' ) ) AS coordinates
FROM users
LIMIT 0 , 50

It returns results properly and displays them as GEOMETRY(), but when i try to visualize them the map turns out to be empty.

Discussion

  • Madhura Jayaratne

    • assigned_to: Madhura Jayaratne
     
  • Madhura Jayaratne

    • summary: GIS Visualization Extension does not work with PointFromText() function --> (ok 4.2.1) GIS Visualization Extension does not work with PointFromText() function
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • Marc Delisle

    Marc Delisle - 2014-05-13
    • status: resolved --> fixed