#4212 (ok 4.1.4) Table "disappears" if it has the same name as its tablegroup

4.1.3
fixed
None
1
2014-01-07
2014-01-03
Sieberkev
No

I hope my description is understandable (English is not my main language).

When you use the grouped/collapsed table names in the menu (it groups/collapses tables on double underscore by default) and you use (as example) the next three names:

  • event
  • event__subtable
  • event__subtable2

This collapses in the menu into the group "event".

When you click on the group "event" in the menu, it does not show the table with the same name as the group (so here "event" has disappeared).

On our server we discovered this behavior with some user/user_ tables and it scared the living crp out of one of my developers. I tested it today on your demo server in the database "menagerie" and it happens there too.

I think this behavior is in PMA since the start of the new menu system.

Discussion

  • Madhura Jayaratne

    You indicated that you have this bug on phpMyAdmin version 4.1.3, is this correct? Unfortunately, I am unable to reproduce the bug on that version. Are you able to reproduce the bug on our demo server (http://demo.phpmyadmin.net/STABLE/) ?

     
    • Sieberkev

      Sieberkev - 2014-01-03

      Yes, I am able to reproduce this on your given link (and on our local 4.1.3 version):

      • I logged in with account "root" (with blanco password)
      • In the database "menagerie" I made 2 new tables: "eventsubtable" and "eventsubtable2" (it's with a double underscore, but the markdown language is funky with it)
      • I refreshed the menu on the left and clicked on the grouped "event" in that menu
      • Only the two subtables will appear in the list, and no trace of the table "event" on the right

      (I added a screenshot, you can see three tables in the menu on the left, but only two on the right)

       
      Last edit: Sieberkev 2014-01-03
  • Marc Delisle

    Marc Delisle - 2014-01-03

    Sieberkev,
    you write "only the two subtables will appear in the list"; I guess your are not referring to the left pane, but only to the right pane, as your screenshot shows the three table names in the left pane.

    Please confirm that there is a problem only in the right pane.

     
    • Sieberkev

      Sieberkev - 2014-01-03

      Marc,

      Yes, I confirm that the table is only missing from the listing on the right and is still visible in the menu on the left (IF you expand it).

       
      Last edit: Sieberkev 2014-01-03
  • Madhura Jayaratne

    • assigned_to: Madhura Jayaratne
     
  • Madhura Jayaratne

    I also thought that you were referring to the left pane.

     
  • Madhura Jayaratne

    • labels: menu -->
    • summary: Table "disappears" if it has the same name as its tablegroup --> (ok 4.1.4) Table "disappears" if it has the same name as its tablegroup
    • status: open --> resolved
    • Priority: 5 --> 1
     
  • Marc Delisle

    Marc Delisle - 2014-01-07
    • Status: resolved --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks