#4124 (ok 4.1) Editing a query from SQL History shows a blank page

4.0.8
fixed
None
1
2014-11-21
2013-10-07
No

I meant to report this months ago as it's been in the whole 4.0.* line I think. Still present in the latest 4.0.8 (from git).

Steps:
1. Click a table name to browse it.
2. Click "Edit" on the SQL query box (i.e. next to Inline, Explain SQL etc)
3. In the popup window, click the SQL History tab.
4. Click the edit icon next to a query.

Expected: A page like the SQL tab to appear with the appropriate query in the textarea.

Actual: Basically a blank page. There is just one checkbox with the label "Do not overwrite this query from outside the window" and nothing else.

Discussion

  • DisgruntledGoat

    DisgruntledGoat - 2013-10-07

    Here is the URL it goes to, if that's of any use:

    /querywindow.php#PMAURL-0:querywindow.php?db=test&table=test&server=1&target=&token=[TOKEN]
    
     
  • Marc Delisle

    Marc Delisle - 2013-10-07

    In IE 10, I can reproduce this problem. In Firefox 23, the message briefly appears, but is replaced by the expected result.

     
  • Marc Delisle

    Marc Delisle - 2013-10-07

    Works fine for me in both browsers, using version 4.1.0-alpha2.

     
  • Marc Delisle

    Marc Delisle - 2013-10-07
    • summary: Editing a query from SQL History shows a blank page --> (ok 4.1) Editing a query from SQL History shows a blank page
    • status: open --> resolved
    • assigned_to: Marc Delisle
    • Priority: 5 --> 1
     
  • DisgruntledGoat

    DisgruntledGoat - 2013-10-08

    I was using Chrome (and same issue in Safari). If I'm using the github version can I switch to the 4.1.0-alpha2 version to test this?

     
  • Marc Delisle

    Marc Delisle - 2013-10-08

    If you have a git repository, you can checkout RELEASE_4_1_0ALPHA2.

     
  • DisgruntledGoat

    DisgruntledGoat - 2013-10-09

    OK checked that out and the issue works fine for me there.

    (By the way... on that version all the icons are messed up: the icon next to SQL is the PDF icon, the logout icon is a gear and so on. Is that a known issue?)

     
  • Marc Delisle

    Marc Delisle - 2013-10-09

    Icons get messed up when you switch versions, running from a git repository. Clear your browser cache and reload the page one or two times.

     
  • Marc Delisle

    Marc Delisle - 2013-12-12
    • Status: resolved --> fixed
     
  • CRWA

    CRWA - 2014-11-20

    Hi:

    I've just updated two servers to Debian 7 Wheezy. Since the version of phpMyAdmin bundled with it is 3.4.11, this bug is present: no query history is registered either in Javascript or in the pma_history table (with the $cfg['QueryHistoryDB'] flag set to "true").

    So, is there a patch to version 3.4.11 or something else that I could use to fix the issue?

    Thanks

     
  • Marc Delisle

    Marc Delisle - 2014-11-21

    On a Debian 7 Wheezy machine I am using the latest stable version (4.2.7). I installed it manually.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks