#3913 (ok 4.0.2) Table search returns empty result

4.0.0
fixed
nobody
None
1
2013-06-11
2013-05-06
No

After upgrading from pma 3.5 to 4.0 some sql queries do not work anymore.
I am using pma on a freebsd 9.1 machine with an up to date portstree, mysql 5.5, apache 2.2 and php 5.4. The apache server has been completely restarted and browser cache was emptied after the upgrade.

On certain queries there is just no result.
To reproduce this, you can create a table with the sql statements from attachment sql-create-table.txt

When doing a simple search query like
SELECT * FROM Members WHERE Id =1
the result looks like screenshot-working.png and everything is fine.

But if I call this query
SELECT * FROM Members WHERE Callsign LIKE 'GA%'
it won't work and I get an output like in screenshot-defective.png. This appears right after submitting the search form when I just use 'GA%' as search pattern for the Callsign column.

There is no error message or anything else giving me at least a hint on how to troubleshoot this. It always seems to be broken as soon as I search for anything in the Callsign column.

I did some debugging with Firebug. I have attached a working AJAX communication in ajax-post-working.txt and ajax-reply-working.txt. In contrast ajax-post-defect.txt and ajax-reply-defect.txt are broken. However I cannot see any big difference in those two requests.

If I can provide you any further details or information in case you cannot reproduce this, please let me know.

regards
David

1 Attachments

Discussion

  • Ayush Choubey

    Ayush Choubey - 2013-05-12

    Ok, this one was one of its kind

    The column name Callsign actually breaks the thing, change it to calsign and it will work just fine. However this is certainly a bug.

    The problem is word call in callsign which is used by procedures.

    I don't have much exposure to procedures in mysql. I guess i will read about it, think about all the possible scenario and then fix it :)

     
  • Ayush Choubey

    Ayush Choubey - 2013-05-14

    This seems to have been fixed with bug #3902

     
  • Madhura Jayaratne

    • summary: Table search returns empty result --> (ok 4.0.2) Table search returns empty result
    • status: open --> open-fixed
    • Priority: 5 --> 1
     
  • Marc Delisle

    Marc Delisle - 2013-05-24
    • Status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks