#3817 (ok 4.0.0) Duplicate Constraints Being Added on Database Copy

3.5.6
fixed
constraints (1)
1
2013-06-11
2013-02-08
No

In v3.5.4 and v3.5.6, I'm running into problems with unexpected constraints being added when I copy an InnoDB database. If I don't check the "Add Constraints" box, the constraints are still added in the copy. If I do check the "Add Constraints" box, duplicates of the constraints are added. Through a couple copies in testing, I ended up with 8 copies of the same constraint.

Bug 3417 appears to be the same issue. It was supposed to have been fixed in v3.5.0 but it looks like the problem is back.

Discussion

  • Madhura Jayaratne

    • assigned_to: Madhura Jayaratne
     
  • Madhura Jayaratne

    • summary: (Duplicate) Constraints Being Added on Database Copy --> (ok 4.0.0) Constraints Being Added on Database Copy
    • status: open --> open-fixed
    • priority: 5 --> 1
     
  • Madhura Jayaratne

    The bug seems to have been fixed in master.

     
  • Madhura Jayaratne

    • summary: (ok 4.0.0) Constraints Being Added on Database Copy --> (ok 4.0.0) Duplicate Constraints Being Added on Database Copy
     
  • Brian Powell

    Brian Powell - 2013-04-05

    I tested the current 4.x master. This problem does appear to be fixed there.

     
  • Marc Delisle

    Marc Delisle - 2013-05-03
    • Status: open-fixed --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks