#3784 Confirm DROP queries does not work

Latest_Git
fixed
None
5
2013-06-11
2013-01-24
No

Disabling "Confirm DROP queries" in user preferences does not make the confirmations go away, at least on following places:

  • dropping multiple databases from database listing
  • dropping database from its operations tab
  • dropping table from its operations tab

Discussion

  • Marc Delisle

    Marc Delisle - 2013-01-28
    • assigned_to: Marc Delisle
     
  • Marc Delisle

    Marc Delisle - 2013-01-28

    I'm not sure that $cfg['Confirm'] should be obeyed in these cases. I would rather change the doc to mention that this directive does not concern "strong" confirmations such as these.

     
  • Michal Čihař

    Michal Čihař - 2013-01-29

    The problem is that the settings has no effect on javascript confirmation, but it does affect those confirmations in PHP - so if I open mentioned links in new tab, the table/database gets immediatelly dropped.

     
  • Marc Delisle

    Marc Delisle - 2013-01-29

    Do you suggest that the behavior at the PHP level should be the same as in js, so that these "strong" confirmations be shown everytime, bypassing $cfg['Confirm'] ?

     
  • Marc Delisle

    Marc Delisle - 2013-01-30
    • assigned_to: Marc Delisle --> nobody
     
  • Marc Delisle

    Marc Delisle - 2013-02-03

    Michal, any feedback to my question?

     
  • Michal Čihař

    Michal Čihař - 2013-02-04

    Looks like I did not receive notification for that...

    Well the PHP checks for confirmation of DROP, DELETE and TRUNCATE if Confirm is enabled. So either javascript code should honor this setting as well or the setting should be dropped. I'd prefer to keep option to disable these warnings and make javascript honor this.

     
  • Marc Delisle

    Marc Delisle - 2013-02-04

    In current master, now that js is mandatory, I could not find one way to execute this confirm logic in sql.php. If you could, tell me the step-by-step.

     
  • Michal Čihař

    Michal Čihař - 2013-02-05

    Go to table operations tab, and open DROP link in new window/tab.

     
  • Marc Delisle

    Marc Delisle - 2013-02-05

    Ok, but this isn't something that would be done in normal circumstances.

     
  • Marc Delisle

    Marc Delisle - 2013-02-05
    • assigned_to: Marc Delisle
     
  • Marc Delisle

    Marc Delisle - 2013-02-06
    • status: open --> closed-fixed
     
  • Michal Čihař

    Michal Čihař - 2013-06-11
    • Status: closed-fixed --> fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks